kmp做题样例Oulipo

原文:
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
翻译:
法国作家乔治·佩雷克(1936-1982)曾经写过一本书,名叫《差距》,没有字母“E”。他是欧利波集团的成员。书中的一句话:

头像对正常,头像的肯定是假的。宣扬公平、正常、堕胎、不人道、冒犯。奥拉伊特·沃卢·萨沃尔·奥塔皮斯的文章《罗马统一运动协会》:搅拌之子塔皮斯,攻击者吹捧瞬间之子的想象力,我的直觉与禁忌,幻象与模糊,空位,不可编辑:幻象,奥布里指挥官吹捧,奥249“废除葡萄干:宣扬一切正常的生活……

佩雷克在接下来的比赛中可能得分很高(或者更确切地说是很低)。人们被要求在某个主题上写一篇可能甚至是有意义的文章,尽可能少地出现一个给定的“单词”。我们的任务是为陪审团提供一个统计这些事件的程序,以便获得竞争对手的排名。这些竞争对手经常写很长的文本,意思很荒谬;连续50万个T的序列并不罕见。他们从不使用空间。

因此,我们想快速了解一个单词,即给定的字符串,在文本中出现的频率。更正式地说:考虑到字母表’a’、‘b’、‘c’、…、'z’和该字母表上的两个有限字符串(一个单词w和一个文本t),计算w在t中出现的次数。w的所有连续字符必须与t的连续字符完全匹配。出现的次数可能会重叠。

输入
输入文件的第一行包含一个数字:要跟踪的测试用例数。每个测试用例都有以下格式:

一行字w,一个在’a’、‘b’、‘c’、……、‘z’上的字符串,1≤w≤10000(此处w表示字符串w的长度)。
一行文字为t,一个字符串位于’a’、‘b’、‘c’、…、‘z’,其中w≤t≤1000000。
输出
对于输入文件中的每个测试用例,输出应该在一行中包含一个数字:文本t中出现单词w的次数。
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
题目描述:
在母串中出子串出现的次数
解题思路
遍历母串,在j等于子串长度是让子串回到第j个字符前有相同前缀的地方继续进行比较知道遍历到母串的最后一个字符
AC代码:

#include<stdio.h>
#include<string.h>
char s[1000001],p[10001];
int next[10001];
int n,m,num;
void Get_next()
{
	int i=1,j=0;
	next[0]=-1;
	while(i<m)
	{
		if(j==-1||p[i]==p[j])
		{
			j++;
			i++;
			next[i]=j;
		}
		else
		{
			j=next[j];
		}
	}
}
void kmp()
{
    Get_next();
	int i=0,j=0;
	while(i<n)
	{
		if(j==-1||s[i]==p[j])
		{
			i++;
			j++;   
		}
		else
		{
			j=next[j];
		}
		if(j==m)
		{
			num++;
			j=next[j];
		}
	}
	printf("%d\n", num);
}
int main()
{
	int t;
	scanf("%d", &t);
	while(t--)
	{
	scanf("%s",p);
	scanf("%s",s);
	n=strlen(s);
	m=strlen(p);
	num=0;
	kmp();	
	}
	return 0;
}
  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

皮皮皮皮皮皮皮卡乒

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值