PAT 甲级 1043 Is It a Binary Search Tree (25 分)(链表建树前序后序遍历)*不会用链表建树 *看不懂题...

1043 Is It a Binary Search Tree (25 分)
 

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

题意:

题目读不懂,看了别人的题解才知道。

题目我纠结了好久才明白是什么意思
给出一个序列,利用这个数建立二叉搜索树

然后问 问这个序列是不是这个二叉搜索树的先序或者是这个二叉树镜像树的先序
如果是 那么就输出Yes 并且输出这个树的后序
如果不是的话就直接输出No

怎么说? 我先利用这个东西建立二叉搜索树...然后求出二叉搜索树的先序 判断是否和序列一样 若是一样则输出后序

或者判断是否和二叉搜索镜像树一样 若是一样则输出后序

二叉镜像搜索树的先序其实就是先根再右再左

后序就是先右再左再根  没有其他了  主要就是题目意思的问题............

题解:

链表建树,一会儿*,一会&,不熟练

分析:

  1.对输入的一段序列生成一棵二叉搜索树

  2.判断:

      a.此二叉树的先序遍历和输入的序列相等,则输出此二叉树的后序遍历序列

      b.在 a 不成立的情况下,求这棵二叉树的镜像先序遍历序列,若和输入的序列相等,则输出二叉树的镜像后序遍历序列

      c.以上都不成立时,输出 "NO"

AC代码:

#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<map>
#include<string>
#include<cstring>
using namespace std;
struct node{
    int v;
    node *l;//l指针(是个结构体的指针)指向哪个地址
    node *r;
};
vector<int>pre,post,mpre,mpost,ori;
int n;
void insert(node* &root,int val){//建树 &不能忘了
    if(root==NULL){
        root = new node;
        root->v=val;
        root->l=root->r=NULL;
        return;
    }else if(val<root->v){
        insert(root->l,val);
    }else{
        insert(root->r,val);
    }
}
void preorder(node *root){//先序
    if(root==NULL){
        return;
    }else{
        pre.push_back(root->v);
        preorder(root->l);
        preorder(root->r);
    }
}
void postorder(node *root){//后序
    if(root==NULL){
        return;
    }else{
        postorder(root->l);
        postorder(root->r);
        post.push_back(root->v);
    }
}
void mpreorder(node *root){//镜像先序
    if(root==NULL){
        return;
    }else{
        mpre.push_back(root->v);
        mpreorder(root->r);
        mpreorder(root->l);    
    }
}
void mpostorder(node *root){//镜像后序
    if(root==NULL){
        return;
    }else{
        mpostorder(root->r);
        mpostorder(root->l);
        mpost.push_back(root->v);
    }
}
int main()
{
    int x;
    cin>>n;
    node *root=NULL;//指针root指向null
    for(int i=1;i<=n;i++)
    {
        cin>>x;
        ori.push_back(x);
        insert(root,x);
    }
    preorder(root);//前序遍历
    mpreorder(root);//镜像前序遍历
    if(pre==ori){
        cout<<"YES\n";
        postorder(root);//后序遍历
        for(int i=0;i<post.size();i++){
            cout<<post[i];
            if(i!=post.size()-1) cout<<" ";
        }
    }
    else if(mpre==ori){
        cout<<"YES\n";
        mpostorder(root);//镜像后序遍历
        for(int i=0;i<mpost.size();i++){
            cout<<mpost[i];
            if(i!=mpost.size()-1) cout<<" ";
        }
    }else{
        cout<<"NO\n";
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/caiyishuai/p/11446845.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值