The Cow Lexicon

Problem Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

 
Input
Line 1: Two space-separated integers, respectively: W and L Line 2: L characters (followed by a newline, of course): the received message Lines 3..W+2: The cows' dictionary, one word per line
 
Output
Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.
 
Sample Input
6 10 browndcodw cow milk white black brown farmer
 
Sample Output
2
 
Source
PKU
 
//本题具有子最优结构,适合运用动态规划,利用数组dp[]保存已经计算过的数值,当再次用到时直接调用
//题意  从给定一个字符串和若干个单词,考虑从字符串中至少删除多少个字符,可使字符串与单词匹配
#include<iostream>
#include<string>
using namespace std;
int main()
{   int i ,j;
    int w,L;
    while(cin>>w>>L)
    {
        int* dp=new int[L+1];
        char* mesg=new char[L];
        string* dict=new string[w];

        cin>>mesg;
        for(i=0;i<w;i++)
            cin>>dict[i];

        dp[L]=0;                                     //dp[i]表示从i到L所删除的字符数

        for(i=L-1;i>=0;i--)                           //从message尾部开始向前检索
        {
            dp[i]=dp[i+1]+1;                      //字典单词和message无法匹配时,删除的字符数(最坏的情况)
            for(j=0;j<w;j++)                         //对字典单词枚举
            {
                int len=dict[j].length();
                if(len<=L-i && dict[j][0]==mesg[i])  //单词长度小于等于当前待匹配message长度
                {                                    //且单词头字母与信息第i个字母相同
                    int pm=i;                       //message的指针
                    int pd=0;                        //单词的指针
                    while(pm<L)                      //单词逐字匹配
                    {
                        if(dict[j][pd]==mesg[pm])

                        {  pd++;
                           pm++;
                        }
                        else pm++;
                        if(pd==len)
                        {                                      //dp[i]中原来保存的是 从i到L 无匹配单词时的需要删除的字符数
                            dp[i]=min(dp[i],dp[pm]+(pm-i)-len);//dp[pm]表示从pm到L删除的字符数
                            break;                            //(pm-i)-pd表示从i到pm删除的字符数
                        }                                     //则dp[pm]+(pm-i)-pd表示从i到L有匹配单词时需要删除的字符数
                    }
                }
            }
        }
        cout<<dp[0]<<endl;                              //表示从第一个单词到最后一个单词这个区间需要删除的最少字符数
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/lp2012/p/3384880.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值