Piotr's ants UVA 10881

Problem D
Piotr's Ants

Time Limit: 2 seconds

 

"One thing is for certain: there is no stopping them;
the ants will soon be here. And I, for one, welcome our
new insect overlords."

 

Kent Brockman

Piotr likes playing with ants. He has n of them on a horizontal pole L cm long. Each ant is facing either left or right and walks at a constant speed of 1 cm/s. When two ants bump into each other, they both turn around (instantaneously) and start walking in opposite directions. Piotr knows where each of the ants starts and which direction it is facing and wants to calculate where the ants will end up T seconds from now.

Input
The first line of input gives the number of cases, N. N test cases follow. Each one starts with a line containing 3 integers: L , T and n (0 <= n <= 10000). The next n lines give the locations of the n ants (measured in cm from the left end of the pole) and the direction they are facing (L or R).

Output
For each test case, output one line containing "Case #x:" followed by n lines describing the locations and directions of the n ants in the same format and order as in the input. If two or more ants are at the same location, print "Turning" instead of "L" or "R" for their direction. If an ant falls off the pole before T seconds, print "Fell off" for that ant. Print an empty line after each test case.

 

Sample InputSample Output
2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R
Case #1:
2 Turning
6 R
2 Turning
Fell off

Case #2:
3 L
6 R
10 R

 

 


Problemsetter: Igor Naverniouk
Alternate solutions: Frank Pok Man Chu and Yury Kholondyrev


 

蚂蚁移动时相互碰撞后反响移动,相当于相互穿过移动,从这个想法出发就可以确定所有蚂蚁的位置,但是下标的确定要经过一番的判断。

蚂蚁移动,不管怎么移动,它的先后的相对位置是不会变的,因此可以利用这一点确定蚂蚁的下标是多少(下标为初始输入的先后顺序值)。

以下为我的程序:

#include<iostream>
#include<cstdio>
#include<algorithm>
#define MAXN 10010
using namespace std;
struct Ants{
    char dir;
    int place,id;
    int state;
}an[MAXN];
struct Record{
  int place,id;
}re[MAXN];
bool cmp(Ants a,Ants b)
{
    return a.place<b.place;
}
bool cmp1(Ants a,Ants b)
{
    return a.id<b.id;
}
bool cmp2(Record r1,Record r2)
{
    return r1.place<r2.place;
}
int main()
{
    int L,T,n;
    int cas;
    cin>>cas;
    int k=0;
    while(cas--)
    {
        k++;
        cin>>L>>T>>n;
        for(int i=0;i<n;i++)
        {
            cin>>an[i].place>>an[i].dir;
            re[i].place=an[i].place;
            re[i].id=i+1;
        }
        sort(an,an+n,cmp);
        sort(re,re+n,cmp2);
        for(int i=0;i<n;i++)
        {
            if(an[i].dir=='L')
            {
                an[i].place-=T;
            }
            else
            {
                an[i].place+=T;
            }
        }
       sort(an,an+n,cmp);
       for(int i=0;i<n;i++)
       {
           an[i].id=re[i].id;
           if(an[i].place<0||an[i].place>L)
           {
               an[i].state=0;
           }
           else if(i<n-1&&an[i].place==an[i+1].place)
           {
               an[i].state=3;
           }
           else if(i>0&&an[i].place==an[i-1].place)
           {
               an[i].state=3;
           }
           else{
               if(an[i].dir=='L')an[i].state=1;
               else an[i].state=2;
           }
       }
//       for(int i=0;i<n;i++)
//       {
//           cout<<an[i].id<<' '<<an[i].place<<endl;
//       }
       sort(an,an+n,cmp1);
       cout<<"Case #"<<k<<":"<<endl;
       for(int i=0;i<n;i++)
       {
           if(an[i].state==0)cout<<"Fell off"<<endl;
           else if(an[i].state==1||an[i].state==2)cout<<an[i].place<<' '<<an[i].dir<<endl;
           else if(an[i].state==3)cout<<an[i].place<<' '<<"Turning"<<endl;
       }
      if(cas!=n-1)cout<<endl;
    }
}


 

转载于:https://www.cnblogs.com/jackwuyongxing/p/3366484.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值