uva 10881 Piotr's Ants (模拟)

                         uva 10881 Piotr's Ants


"One thing is for certain: there is no stopping them;
the ants will soon be here. And I, for one, welcome our
new insect overlords."
Kent Brockman

Piotr likes playing with ants. He has n of them on a horizontal pole L cm long. Each ant is facing either left or right and walks at a constant speed of 1 cm/s. When two ants bump into each other, they both turn around (instantaneously) and start walking in opposite directions. Piotr knows where each of the ants starts and which direction it is facing and wants to calculate where the ants will end up T seconds from now.

Input
The first line of input gives the number of cases, N. N test cases follow. Each one starts with a line containing 3 integers: L , T and n (0 <= n <= 10000) . The next n lines give the locations of the n ants (measured in cm from the left end of the pole) and the direction they are facing (L or R).

Output
For each test case, output one line containing "Case #x:" followed by n lines describing the locations and directions of the n ants in the same format and order as in the input. If two or more ants are at the same location, print "Turning" instead of "L" or "R" for their direction. If an ant falls off the pole beforeT seconds, print "Fell off" for that ant. Print an empty line after each test case.

Sample InputSample Output
2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R
Case #1:
2 Turning
6 R
2 Turning
Fell off

Case #2:
3 L
6 R
10 R


题目大意:第一个数据代表数据组数,接下来三个数据 L T n ,分别代表棍长,时长以及蚂蚁数量,接下来n行是蚂蚁的初始位置以及初始方向。要求求出经过T秒后,各蚂蚁的状况。(相对棍子左端的距离,方向)蚂蚁相撞后会各自回头。若经过T秒后,两蚂蚁处于相同位置,则输出“该位置 + Turning”,若已离开木棍(刚好在木棍两端不算)输出“Fell off”,否则输出当前蚂蚁的状态。

解题思路:可以将相撞的蚂蚁,看成是对穿而过。只要记录各蚂蚁的起始编号,在模拟完成后,该蚂蚁的编号位置不会变。


#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
struct ANTS {
	int num;
	int pos;
	char dir;
};
int cmp(ANTS a, ANTS b) {
	return a.pos < b.pos;
}
ANTS ants[10005], antsb[10005];
int kep[10005];
int main() {
	int m, cnt = 1;
	scanf("%d", &m);
	while (m--) {
		int L, T, n, tempi;
		char tempc;
		scanf("%d %d %d", &L, &T, &n);
		for (int i = 1; i <= n; i++) {
			scanf("%d %c\n", &tempi, &tempc);	
			ants[i].num = 0;
			antsb[i].num = i;
			ants[i].pos = antsb[i].pos = tempi;
			ants[i].dir = antsb[i].dir = tempc;
		}
		sort(antsb + 1, antsb + n + 1, cmp);
		for (int i = 1; i <= n; i++) {
			kep[antsb[i].num] = i;
		}
		for (int i = 1; i <= n; i++) {
			if (ants[i].dir == 'R') {
				ants[i].pos += T;
			}
			else ants[i].pos -= T;
		}
		sort(ants + 1, ants + n + 1, cmp);
		for (int i = 1; i < n; i++) {
			if (ants[i].pos == ants[i + 1].pos) {
				ants[i].dir = ants[i + 1].dir = 'T';
			}
		}
		printf("Case #%d:\n", cnt++);
		for (int i = 1; i <= n; i++) {
			int a = kep[i];
			if (ants[a].pos < 0 || ants[a].pos > L) {
				printf("Fell off\n");
				continue;
			}
			if (ants[a].dir == 'T') {
				printf("%d Turning\n", ants[a].pos);
				continue;
			}
			else printf("%d %c\n", ants[a].pos, ants[a].dir);
		}
		printf("\n");
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值