STL-夏天来了~~好开心啊,呵呵,好多好多水果~~-C++

Introduction
Joe经营着一个不大的水果店.

他认为生存之道就是经营最受顾客欢迎的水果.

现在他想要一份水果销售情况的明细表,

这样Joe就可以很容易掌握所有水果的销售情况了.

Input

第一行正整数N(0<N<=10)表示有N组测试数据.
每组测试数据的第一行是一个整数M(0<M<=100),

表示工有M次成功的交易.其后有M行数据,每行表示一次交易,

由水果名称(小写字母组成,长度不超过80),

水果产地(小写字母组成,长度不超过80)和交易的水果数目(正整数,不超过100)组成.

Output

对于每一组测试数据,请你输出一份排版格式正确(请分析样本输出)的水果销售情况明细表.

这份明细表包括所有水果的产地,名称和销售数目的信息.

水果先按产地分类,产地按字母顺序排列;

同一产地的水果按照名称排序,名称按字母顺序排序.
两组测试数据之间有一个空行.

最后一组测试数据之后没有空行.

Sample Input

1
5
apple shandong 3
pineapple guangdong 1
sugarcane guangdong 1
pineapple guangdong 3
pineapple guangdong 1

Sample Output

guangdong
   |----pineapple(5)
   |----sugarcane(1)
shandong
   |----apple(3)

代码

思路:一开始想到province和fruit要绑定在一起考虑排序,但用优先队列发现不能用;转而使用单独的结构体数组,也不能解决问题;最后使用map<结构体,int>,并测试成功;

要点:设置key的时候,需要在结构体中对运算符<进行重载。

#include <iostream>
#include <algorithm>
#include <vector>
#include <string>
#include <math.h>
#include <queue>
#include <map>
using namespace std;

struct node1{
    string pro;
    string fruit;
    //重载运算符
    bool operator < (node1 const& b)const{
        if(pro==b.pro){
            return fruit<b.fruit;
        }
        else{
            return pro<b.pro;
        }
    }
};

int main(){
    int t;
    int num;
    cin>>t;
    map <node1,int> a;
    node1 temp;
    string temPro;
    string tempFruit;
    int tempNum=0;

    while(t--){
        cin>>num;
        for(int i = 0;i < num;i++){
            cin>>tempFruit>>temPro>>tempNum;
            temp.pro=temPro;
            temp.fruit=tempFruit;
            a[temp]+=tempNum;
        }
        map<node1,int>::iterator iter=a.begin();
        string haha=iter->first.pro;
        cout<<haha<<endl;
        for(;iter!=a.end();iter++){
            if(iter->first.pro!=haha){
                haha=iter->first.pro;
                cout<<haha<<endl;
            }
            cout<<"   |----"<<iter->first.fruit<<"("<<iter->second<<")"<<endl;
        }



        a.clear();
        if(t!=0){
            cout<<endl;
        }
    }
}

 

  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值