poj 2833 The Average

The Average
Time Limit: 6000MS Memory Limit: 10000K
Total Submissions: 8989 Accepted: 2811
Case Time Limit: 4000MS

Description

In a speech contest, when a contestant finishes his speech, the judges will then grade his performance. The staff remove the highest grade and the lowest grade and compute the average of the rest as the contestant’s final grade. This is an easy problem because usually there are only several judges.

Let’s consider a generalized form of the problem above. Given n positive integers, remove the greatest n1 ones and the least n2 ones, and compute the average of the rest.

Input

The input consists of several test cases. Each test case consists two lines. The first line contains three integers n1n2 and n (1 ≤ n1n2 ≤ 10, n1 + n2 < n ≤ 5,000,000) separate by a single space. The second line contains n positive integers ai (1 ≤ ai ≤ 108 for all i s.t. 1 ≤ i ≤ n) separated by a single space. The last test case is followed by three zeroes.

Output

For each test case, output the average rounded to six digits after decimal point in a separate line.

Sample Input

1 2 5
1 2 3 4 5
4 2 10
2121187 902 485 531 843 582 652 926 220 155
0 0 0

Sample Output

3.500000
562.500000

Hint

This problem has very large input data. scanf and printf are recommended for C++ I/O.

The memory limit might not allow you to store everything in the memory.

Source

[Submit]   [Go Back]   [Status]   [Discuss]

/*=============================================================================
#     FileName: 2833.cpp
#         Desc: 
#       Author: zhuting
#        Email: cnjs.zhuting@gmail.com
#     HomePage: my.oschina.net/locusxt
#      Version: 0.0.1
#    CreatTime: 2013-12-22 18:12:25
#   LastChange: 2013-12-22 18:12:25
#      History:
=============================================================================*/
#include <cstdio>
#include <cstdlib>
#include <string>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;

int main()
{
	int n1 = 0, n2 = 0, n = 0;
	int tmp = 0;
	while (true)
	{
		long long ans = 0;
		int pqn1 = 0, pqn2 = 0;
		priority_queue<int, vector<int>, greater<int> > pq1;
		priority_queue<int, vector<int>, less<int> > pq2;
		scanf("%d%d%d", &n1, &n2, &n);
		if (n1 == 0 && n2 == 0 && n == 0)
			break;
		for (int i = 0 ; i < n; ++i)
		{
			scanf("%d", &tmp);
			ans += tmp;
			if (pqn1 < n1)
			{
				pq1.push(tmp);
				++pqn1;
			}
			else
			{
				if (tmp > pq1.top())
				{
					pq1.pop();
					pq1.push(tmp);
				}
			}
			if (pqn2 < n2)
			{
				pq2.push(tmp);
				++pqn2;
			}
			else
			{
				if (tmp < pq2.top())
				{
					pq2.pop();
					pq2.push(tmp);
				}
			}
		}
		for (int i = 0 ; i < n1; ++i)
		{
			ans -= pq1.top();
			pq1.pop();
		}
		for (int i = 0 ; i < n2; ++i)
		{
			ans -= pq2.top();
			pq2.pop();
		}

		printf("%.6lf\n", ((double)ans) / (double)(n - n1 - n2));
	}
	return 0;
}




转载于:https://my.oschina.net/locusxt/blog/186671

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值