POJ2833 The Average【单调队列】

该博客介绍了一个竞赛评分问题,需要去除最高分和最低分后计算平均值。提出了使用单调队列(最大值优先队列和最小值优先队列)来高效解决,并给出了代码实现。
摘要由CSDN通过智能技术生成

题目:

In a speech contest, when a contestant finishes his speech, the judges will then grade his performance. The staff remove the highest grade and the lowest grade and compute the average of the rest as the contestant’s final grade. This is an easy problem because usually there are only several judges.

Let’s consider a generalized form of the problem above. Given npositive integers, remove the greatest n1 ones and the least n2 ones, and compute the average of the rest.

Input

The input consists of several test cases. Each test case consists two lines. The first line contains three integers n1, n2 and n (1 ≤ n1, n2 ≤ 10, n1 + n2 < n ≤ 5,000,000) separate by a single space. The second line contains n positive integers ai (1 ≤ ai ≤ 108 for all is.t. 1 ≤ i ≤ n) separated by a single space. The last test case is followed by three zeroes.

Output

For each test case, output the average rounded to six digits after decimal point in a separate line.

Sample Input

1 2 5
1 2 3 4 5
4 2 10
2121187 902 485 531 843 582 652 926 220 155
0 0 0

Sample Output

3.500000
562.500000

Hint

This problem has very large input data. scanf and printf are recommended for C++ I/O.

The memory limit might not allow you to store everything in the memory.

题目大意: 

       共 n 个评委对选手打分,去除 n1 个最高分,去除 n2 个最低分,求其余值的平均值并保留六位小数输出。

解题思路:

       用两个优先队列分别按最大值优先,最小值优先存储,用不断判断队列中数目的方法模拟单调队列出栈,最后用全部值的和减去这两个队列中的值。

       PS:输出保留多少位的小数,格式!!!

实现代码:

#include <cstdio>
#include <iostream>
#include <queue>
#include <vector>
using namespace std;
typedef long long ll;
int main(){
    int n1, n2, n, x;
    while(scanf("%d%d%d",&n1,&n2,&n)&&n!=0){
        priority_queue<int,vector<int>,less<int> >qsmall;  //最小优先队列
        priority_queue<int,vector<int>,greater<int> >qbig; //最大优先队列
        double sum=0.0;
        for(int i=0;i<n;i++){
            scanf("%d",&x);
            sum+=x; //求分数之和

            qsmall.push(x); //入队
            qbig.push(x);

            if(qsmall.size()>n2)    //维护队列
                qsmall.pop();
            if(qbig.size()>n1)
                qbig.pop();
        }

        for(int i=0;i<n1;i++){  //去除n1个最小值&n2个最大值
            sum-=qbig.top();
            qbig.pop();
        }
        for(int i=0;i<n2;i++){
            sum-=qsmall.top();
            qsmall.pop();
        }
        printf("%.6f\n",sum/(n-n1-n2));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值