POJ 2833 The Average 堆排序

In a speech contest, when a contestant finishes his speech, the judges will then grade his performance. The staff remove the highest grade and the lowest grade and compute the average of the rest as the contestant’s final grade. This is an easy problem because usually there are only several judges.

Let’s consider a generalized form of the problem above. Given n positive integers, remove the greatest n1 ones and the least n2 ones, and compute the average of the rest.

Input

The input consists of several test cases. Each test case consists two lines. The first line contains three integers n1n2 and n (1 ≤ n1n2 ≤ 10, n1 + n2 < n ≤ 5,000,000) separate by a single space. The second line contains n positive integersai (1 ≤ ai ≤ 108 for all i s.t. 1 ≤ i ≤ n) separated by a single space. The last test case is followed by three zeroes.

Output

For each test case, output the average rounded to six digits after decimal point in a separate line.

Sample Input
1 2 5
1 2 3 4 5
4 2 10
2121187 902 485 531 843 582 652 926 220 155
0 0 0
Sample Output
3.500000
562.500000
Hint

This problem has very large input data. scanf and printf are recommended for C++ I/O.

The memory limit might not allow you to store everything in the memory.


输入三个数n1,n2,n;代表一共n个数,去掉n1个最大的数,去掉n2个最小的数,求其它的数平均值

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int  n1,n2,h1[12],h2[12];
void swap(int x,int y,int h[])
{
    int t;
    t=h[x];
    h[x]=h[y];
    h[y]=t;
}
void siftdown_min(int i)
{
    int t,flag=0;
    while(i*2<=n1&&flag==0)
    {
        if(h1[i]>h1[i*2]) //t用来记录最小节点的编号
            t=i*2;
        else
            t=i;
        if(i*2+1<=n1)
        {
            if(h1[t]>h1[i*2+1])
                t=i*2+1;
        }
        if(t!=i) //最小节点的编号不是自己,说明子节点中有比父节点更小的,交换位置
        {
            swap(t,i,h1);
            i=t; //更新i为刚才与它交换的儿子节点的编号,便于继续向下调整
        }
        else
            flag=1;//已经是最小的,不需要调整了
    }
}
void siftdown_max(int i)
{
    int t,flag=0;
    while(i*2<=n2&&flag==0)
    {
        if(h2[i]<h2[i*2])
            t=i*2;
        else
            t=i;
        if(i*2+1<=n2)
        {
            if(h2[t]<h2[i*2+1])
                t=i*2+1;
        }
        if(t!=i)
        {
            swap(t,i,h2);
            i=t;
        }
        else
            flag=1;
    }
}
void creat_min()
{
    for(int i=n1/2; i>=1; i--)
        siftdown_min(i);
}
void creat_max()
{
    for(int i=n2/2; i>=1; i--)
        siftdown_max(i);
}
int main()
{
    int n,m;
    while(~scanf("%d%d%d",&n1,&n2,&n))
    {
        if(!n1&&!n2&&!n) break;
        long long sum=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&m);
            sum+=m;
            if(i<=n1)
                h1[i]=m;
            if(i<=n2)
                h2[i]=m;
            if(i==n1)
                creat_min();//建堆(建立最小堆,找出最大值)
            if(i>n1)
            {
                if(m>h1[1]) //保证堆里面都是最大的数
                {
                    h1[1]=m;
                    siftdown_min(1);
                }
            }
            if(i==n2) 
                creat_max();//建堆(建立最大堆,找出最小值)
            if(i>n2)
            {
                if(m<h2[1]) //保证堆里面都是最小的数
                {
                    h2[1]=m;
                    siftdown_max(1);
                }
            }
        }
        for(int i=1; i<=n1; i++)
            sum-=h1[i];
        for(int i=1; i<=n2; i++) //分别减去最大最小的那几个数
            sum-=h2[i];
        printf("%.6f\n",sum*1.0/(n-n1-n2));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值