POJ2230 Watchcow

POJ - 2230 

Watchcow

Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done. 

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see. But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice. 

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input

* Line 1: Two integers, N and M. 

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

Output

* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input

4 5
1 2
1 4
2 3
2 4
3 4

Sample Output

1
2
3
4
2
1
4
3
2
4
1

Hint

OUTPUT DETAILS: 

Bessie starts at 1 (barn), goes to 2, then 3, etc...
刷一本书,就是图论及其应用
第一道题就是求欧拉回路,直接写邻接表简单些,好像我用vector写的不太顺利
就是dfs序
#include<stdio.h>
#include<string.h>
const int M=100007;
int vis[M],head[M],path[M];
int n,m,tot,num;
struct Node
{
    int to,nxt;
} E[M];
void add(int a,int b)
{
    E[tot].to=b,E[tot].nxt=head[a],head[a]=tot++;
}
void dfs(int u)
{
    for(int v=head[u],nxt; v!=-1; v=E[v].nxt)
    {
        nxt=E[v].to;
        if(!vis[v])
            vis[v]=1,dfs(nxt);
    }
    path[num++]=u;
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        tot=num=0;
        memset(vis,0,sizeof(vis));
        memset(head,-1,sizeof(head));
        for(int i=1,a,b; i<=m; i++)
            scanf("%d%d",&a,&b),add(a,b),add(b,a);
        dfs(1);
        for(int i=0; i<num; i++)
            printf("%d\n",path[i]);
    }
    return 0;
}

直接vector的

#include<stdio.h>
#include<vector>
using namespace std;
const int N=1e4+5;
int n,m;
struct Node
{
    int to,f;
} t;
vector<Node>G[N];
void dfs(int u)
{
    int l=G[u].size();
    for(int i=0,v; i<l; i++)
    {
        if(!G[u][i].f)G[u][i].f=1,dfs(G[u][i].to);
    }
    printf("%d\n",u);
}
int main()
{
    scanf("%d%d",&n,&m);
    t.f=0;
    for(int i=1,a,b; i<=m; i++)
    {
        scanf("%d%d",&a,&b);
        t.to=b;
        G[a].push_back(t);
        t.to=a;
        G[b].push_back(t);
    }
    dfs(1);
    return 0;
}

 

转载于:https://www.cnblogs.com/BobHuang/p/8166885.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值