POJ-2387 the Cows Come Home

Til the Cows Come Home
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 39318 Accepted: 13371

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

 

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Bellman-Ford算法代码简单,对于负圈也可以进行处理,但是复杂度比较高

 

#include<cstdio>
#define MAXN 2100
using namespace std;
const int INF=999999;
struct edge{
    int v,u,cost;
}es[MAXN];
int d[MAXN];
int v,e; 
int main()
{
    int n,m;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&es[i].v,&es[i].u,&es[i].cost);
        }
        for(int i=0;i<=n;i++)    d[i]=INF;
        d[1]=0;
        while(true)
        {
            bool update=false;
            for(int i=0;i<=m;i++)
            {
                edge e=es[i];
                if(d[e.v]!=INF&&d[e.u]>d[e.v]+e.cost){
                    d[e.u]=d[e.v]+e.cost;
                    update=true;
                }
                if(d[e.u]!=INF&&d[e.v]>d[e.u]+e.cost)
                {
                    d[e.v]=d[e.u]+e.cost;
                    update=true;
                }
            }
            if(!update)     break;
        }
        printf("%d\n",d[n]);
    }
    return 0;
} 

 

下面是Dijkstra

 

#include<iostream>
#include<cstring>
#include<cstdio>
#define MAXN 1005
#define min(a,b) (a<b)?a:b;
using namespace std;
const int INF=999999;
int cost[MAXN][MAXN];
bool vis[MAXN];
int t,n,d[MAXN]; 
int main()
{
    int t,n;
    while(scanf("%d%d",&t,&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                cost[i][j]=INF;
        for(int j=0;j<t;j++)
        {
            int a,b,len;
            scanf("%d%d%d",&a,&b,&len);
            if(cost[a][b]>len)
                cost[a][b]=cost[b][a]=len;
        }
        memset(d,INF,sizeof(d));
        memset(vis,false,sizeof(vis));
        d[1]=0; 
        while(true)
        {
            int v=-1;
            for(int u=1;u<=n;u++)
            {
                if(!vis[u]&&(v==-1||d[u]<d[v]))    v=u;
            }
            if(v==-1)    break;
            vis[v]=true;
            for(int u=1;u<=n;u++){
                d[u]=min(d[u],d[v]+cost[v][u]);
            }
        }
        printf("%d\n",d[n]);         
    }
    return 0;
}

 


 

转载于:https://www.cnblogs.com/cniwoq/p/6770982.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值