POJ2387::Til the Cows Come Home dijkstra算法

本文介绍了如何应用Dijkstra算法解决POJ2387问题,该问题涉及寻找奶牛Bessie从田地中的最后一个地标返回谷仓的最短路径。通过示例输入和输出,解释了算法的运用,并提供了相关资源以深入理解。
摘要由CSDN通过智能技术生成

Dijkstra算法

Dijkstra算法大致上是利用贪心思想实现的,首先把起点到所有点的距离存下来找个最短的,然后遍历一遍看通过刚刚找到的距离最短的点作为中转点会不会更近,如果更近了就更新距离,这样把所有的点遍历之后就存下了起点到其他所有点的最短距离。然后将最短点的距离输出。
下面咱们来看一下这个题:

Til the Cows Come Home POJ - 2387

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1…N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

  • Line 1: Two integers: T and N

  • Lines 2…T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1…100.

Output

  • Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
    Sample Input
    5 5
    1 2 20
    2 3 30
    3 4 20
    4 5 20
    1 5 100
    Sample Output
    90
    具体思路:
    n个点m条边的无向图,求1到n的最短路径.
    这个题可以直接用Dijkstra算法写出来。也可以再优化。具体的优化这里就不说了。

    重点来了:
    代码!!!!!
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX 99999
using namespace std ;
int u , v ,n, dis[1000],vis[1000],kg[1000][1000];
void dijk()
{
	int k , mini;
	for(int i=1 ; i<=v;i++)
	{
		dis[i]=kg[1][i];
	}
	for(int i = 1  ;i<=v ;i++)
	{
		mini=MAX;
		for(int j = 1 ; j<=v;j++)
		{
			if(!vis[j]&&dis[j]<mini)
			{
				mini=dis[j];
				k=j;
			}
		}
		vis[k]=1;
		for(int j=1 ;j<=v;j++)
		{
			if(dis[j]>dis[k]+kg[k][j])
			{
				dis[j]=dis[k]+kg[k][j];
			}
		}
	}
	
}
int main()
{
	while(cin>>u>>v)
	{
		n=0;
		for(int i = 0 ; i <=v;i++)
		{
			for(int j = 0 ; j <=v;j++)
			{
				kg[i][j]=MAX;
			}
			kg[i][i]=0;
			vis[i]=0;
			dis[i]=MAX;
		}
		for(int i = 1 ;i<=u;i++)
		{
			int a , b , len;
			cin>>a>>b>>len;
			n=max(max(n,a),b);
			if(kg[a][b]>len)
			{
				kg[a][b]=kg[b][a]=len;
			}
		}
		dijk();
		printf("%d\n",dis[v]);
	}
	return 0 ;
}


如果有不太懂得地方可以去看一下这个。(大佬写的)
https://blog.csdn.net/lbperfect123/article/details/84281300
感觉说的挺好。
有什么问题也可以在下面说,一起交流一起进步。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值