最短路径—— Til the Cows Come Home

https://vjudge.net/problem/POJ-2387
原文:
Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1…N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input

  • Line 1: Two integers: T and N

  • Lines 2…T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1…100.
    Output

  • Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
    Sample Input
    5 5
    1 2 20
    2 3 30
    3 4 20
    4 5 20
    1 5 100
    Sample Output
    90
    题意描述:
    找出n到1号的最短距离
    解题思路:
    用单源最短路径去求,求出后输出dis[1]就行,写的话很容易,就是在输入的时候容易有陷阱,例如给两组数:
    2 1 3
    2 1 6
    这样的话本来2->1的最短路是3结果被后来输入的6覆盖了;
    AC代码:

#include<stdio.h>
#include<string.h>
int inf=99999999;
int book[10050];
int e[10000][10000],dis[10500];
int main()
{
    int n,m,i,j,min,u,v,w;
    while(scanf("%d %d", &m,&n)!=EOF)
    {
    //初始化数组
    	for(i=1; i<=n; i++)
       {
       	for(j=1; j<=n; j++)
       	{
       		if(i==j)
       		e[i][j]=0;
       		else
       		e[i][j]=inf;
   		}
   	}
   	//输入数据
      for(i=1; i<=m; i++)
       {
       	scanf("%d %d %d",&u,&v,&w);
       	{
       	//题目所设陷阱的地方
       		if(w<e[u][v])
       		{ 
       			e[u][v]=e[v][u]=w;
       		}
   		}
       
   	}
               for(i=1; i<=n; i++)
   			{
               	dis[i]=e[1][i];
   			}
   			memset(book,0,sizeof(book));
   			   book[1]=1;
   			 for(i=1; i<=n; i++)
   			 {
   			     min=inf;	
   			 	for(j=1; j<=n; j++)
   			 	{
   			 	 if(book[j]==0&&min>dis[j])
   				{
   					 u=j;
   					 min=dis[j];
   					}
   				 }
   				 book[u]=1;
   				 for(v=1; v<=n; v++)
   				 {
   				 	if(e[u][v]<inf)
   				 	{
   				 		if(dis[v]>e[u][v]+dis[u])
   				 		  dis[v]=e[u][v]+dis[u];
   					 }
   				 }
   			  } 
         printf("%d\n", dis[n]);
    }  
   return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

皮皮皮皮皮皮皮卡乒

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值