Uva 375 - Inscribed Circles and Isosceles Triangles

Inscribed Circles and Isosceles Triangles 

Given two real numbers

 

B
the width of the base of an isosceles triangle in inches
H
the altitude of the same isosceles triangle in inches

 

Compute to six significant decimal places

 

C
the sum of the circumferences of a series of inscribed circles stacked one on top of another from the base to the peak; such that the lowest inscribed circle is tangent to the base and the two sides and the next higher inscribed circle is tangent to the lowest inscribed circle and the two sides, etc. In order to keep the time required to compute the result within reasonable bounds, you may limit the radius of the smallest inscribed circle in the stack to a single precision floating point value of 0.000001.

 

For those whose geometry and trigonometry are a bit rusty, the center of an inscribed circle is at the point of intersection of the three angular bisectors.

 

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
The input will be a single line of text containing two positive single precision real numbers (B H) separated by spaces.

 

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.
The output should be a single real number with twelve significant digits, six of which follow the decimal point. The decimal point must be printed in column 7.

 

Sample Input

1

0.263451 0.263451

Sample Output

     0.827648

#include<stdio.h>
#include<math.h>
int main()
{

    double b, h, l, sum, temp, r ;
    double Pl = acos(-1.0); // 其实我只知道别人是用这个的,我AC前用3.14159265358都是WA呀 
    int T;
    scanf("%d", &T);
    while(T--)
    {
        sum = l = r = 0;
        scanf("%lf%lf", &b, &h);
        while(1)
        {
            l = atan(h/(b/2));
            r = tan(l/2)*b/2;
            if(r < 0.000001) break;
            sum += 2*r*Pl;
            b = b*(h-2*r)/h, h = h - 2*r;
        }
        
        printf("%13.6lf\n", sum);
        if(T != 0) printf("\n");
    }
    return 0;
}

解题报告:

其实这题我不想写题解的,一是因为它简单,二是一个Pi的声明也用了我几个WA,但想到做人还是有始有终才行,所以……

转载于:https://www.cnblogs.com/liaoguifa/archive/2013/03/11/2954543.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值