NanoApe Loves Sequence Ⅱ(尺取法)

题目链接:NanoApe Loves Sequence Ⅱ

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 339    Accepted Submission(s): 165


Problem Description
NanoApe, the Retired Dog, has returned back to prepare for for the National Higher Education Entrance Examination!

In math class, NanoApe picked up sequences once again. He wrote down a sequence with  n numbers and a number m on the paper.

Now he wants to know the number of continous subsequences of the sequence in such a manner that the k-th largest number in the subsequence is no less than m.

Note : The length of the subsequence must be no less than k.
 

 

Input
The first line of the input contains an integer  T, denoting the number of test cases.

In each test case, the first line of the input contains three integers n,m,k.

The second line of the input contains n integers A1,A2,...,An, denoting the elements of the sequence.

1T10, 2n200000, 1kn/2, 1m,Ai109
 

 

Output
For each test case, print a line with one integer, denoting the answer.
 

 

Sample Input
1 7 4 2 4 2 7 7 6 5 1
 

 

Sample Output
18
 
题解:
前缀和真是个好东西。前缀和可以是前n个的和,前n项的最小值,前n项的最大值。。。
这个题用到前n项大于m的个数。然后用个尺取法。
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn = 200005;
int a[maxn];
int prek[maxn];
int main()
{
    int T;cin>>T;
    while(T--)
    {
        int n,m,k;
        cin>>n>>m>>k;
        memset(prek,0,sizeof(prek));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            if(a[i]>=m) prek[i] += prek[i-1]+1;
            else prek[i] = prek[i-1];
        }
        long long ans = 0;
        int sum = 0;
        int t = 1;
        for(int l=0;l<=n;l++)
        {
            while(t<=n&&sum<k)
            {
                sum = prek[t]-prek[l];
                t++;
            }
            if(sum<k) break;
            ans += (n-t+2);
            sum = prek[t-1]-prek[l+1];
        }
        printf("%I64d\n",ans);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/littlepear/p/5745200.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值