hdu 5806 NanoApe Loves Sequence Ⅱ(乘法原理/尺取法)

NanoApe Loves Sequence Ⅱ

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 152    Accepted Submission(s): 72


Problem Description
NanoApe, the Retired Dog, has returned back to prepare for for the National Higher Education Entrance Examination!

In math class, NanoApe picked up sequences once again. He wrote down a sequence with  n  numbers and a number  m  on the paper.

Now he wants to know the number of continous subsequences of the sequence in such a manner that the  k -th largest number in the subsequence is no less than  m .

Note : The length of the subsequence must be no less than  k .
 

Input
The first line of the input contains an integer  T , denoting the number of test cases.

In each test case, the first line of the input contains three integers  n,m,k .

The second line of the input contains  n  integers  A1,A2,...,An , denoting the elements of the sequence.

1T10, 2n200000, 1kn/2, 1m,Ai109
 

Output
For each test case, print a line with one integer, denoting the answer.
 

Sample Input
  
  
1 7 4 2 4 2 7 7 6 5 1
 

Sample Output
  
  
18
 

题意:退役狗 NanoApe 滚回去学文化课啦!
在数学课上,NanoApe 心痒痒又玩起了数列。他在纸上随便写了一个长度为 n 的数列,他又根据心情写下了一个数 m。
他想知道这个数列中有多少个区间里的第 k 大的数不小于 m,当然首先这个区间必须至少要有 k 个数啦。

思路:由于题目要求的区间是第k大数>=m,换言之,我们只要求出一些区间里面至少有k个数>=m即可

那么我们可以从左往右扫,每次找到k个>=m的数的时候就把(左界到上一个>=m的数的距离)*(右边剩余的数)即可,显然这些区间必然至少有k个>=m的数,并且不会算多不会算少,

另外按照官方题解也可以用尺取法,也是只要保证区间里至少有k个数>=m即可

代码1:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
#define N 200050
int a[N];
long long d[N];
int main()
{
    int T,n,m,k;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d %d",&n,&m,&k);
        int t=0;
        long long sum=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            if(a[i]>=m)
            {
                d[++t]=i;
                if(t>=k)
                {
                    if(t==k) sum+=d[1]*(n-i+1);
                    else sum+=(d[t-k+1]-d[t-k])*(n-i+1);
                }
            }
        }
        printf("%lld\n",sum);
    }
    return 0;
}

代码2:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
#define N 200050
int a[N];
int main()
{
    int T,n,m,k;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d %d",&n,&m,&k);
        int t=0;
        long long sum=0;
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
        int r=1,num=0;
        for(int i=1;i<=n;i++)
        {
            while(r<=n&&num<k)
            {
                if(a[r]>=m) num++;
                r++;
            }
            if(num>=k) sum+=n-r+2;
            if(a[i]>=m) num--;
        }
        printf("%lld\n",sum);
    }
    return 0;
}





  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值