NanoApe Loves Sequence Ⅱ (尺取法)

NanoApe, the Retired Dog, has returned back to prepare for for the National Higher Education Entrance Examination! 

In math class, NanoApe picked up sequences once again. He wrote down a sequence with nn numbers and a number mm on the paper. 

Now he wants to know the number of continous subsequences of the sequence in such a manner that the kk-th largest number in the subsequence is no less than mm. 

Note : The length of the subsequence must be no less than kk.

Input

The first line of the input contains an integer TT, denoting the number of test cases. 

In each test case, the first line of the input contains three integers n,m,kn,m,k. 

The second line of the input contains nn integers A1,A2,...,AnA1,A2,...,An, denoting the elements of the sequence. 

1≤T≤10, 2≤n≤200000, 1≤k≤n/2, 1≤m,Ai≤1091≤T≤10, 2≤n≤200000, 1≤k≤n/2, 1≤m,Ai≤109

Output

For each test case, print a line with one integer, denoting the answer.

Sample Input

1
7 4 2
4 2 7 7 6 5 1

Sample Output

18

题意:给你n个数,找出有多少个子区间含(第k大的数大于等于m) ; 反过来想:就是找,多少个区间里有至少k个大于等于m的数

#include<iostream>
using namespace std;
typedef long long ll;   //int 存不下 
int a[250000];
int main(){
	ios::sync_with_stdio(false);  //不加速会TLE 
	cin.tie(0);
	cout.tie(0);   
	int t;
	cin>>t;
	while(t--){
		int n,m,k;
		cin>>n>>m>>k;
		for(int i=0;i<n;i++){
			cin>>a[i];
		}
		ll ans=0;
		int count=0;        //记录每个小区间的元素个数 
		int r=0;            //左标尺 
		for(int i=0;i<n;i++){
			while(r<n&&count<k){
				if(a[r]>=m) 
				count++;
				r++;
			}
			if(count>=k) 
			ans+=n-1-r+2; //看图 
			if(a[i]>=m) 
			count--;     //标尺右移 
		}
		cout<<ans<<endl; 
	}
	return 0;
} 

图;凑合看吧QAQ

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值