R1#sh run
Building configuration...
key chain RIP_authen                                         RIP验证
key 1
key-string pass
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.51.1.2 255.255.0.0
ip rip advertise 5
duplex full
standby 1 ip 10.51.1.51
standby 1 priority 100                                              HSPR缺省优先级
standby 1 preempt
!
interface Serial2/1
ip address 10.21.1.2 255.255.0.0
ip rip advertise 5
ip rip authentication key-chain RIP_authen
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
no arp frame-relay
frame-relay map ip 10.21.1.1 112 broadcast
no frame-relay inverse-arp
!
router rip
version 2
timers basic 5 15 0 30
network 10.0.0.0
no auto-summary
!
ip classless
no ip http server

ntp clock-period 17179869                                                   配置NTP
ntp server 10.21.1.1 source FastEthernet0/0
!
end
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.51.1.1 to network 0.0.0.0
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
R       10.3.0.0/16 [120/5] via 10.21.1.1, 00:00:03, Serial2/1
R       10.6.0.0/16 [120/2] via 10.51.1.1, 00:00:02, FastEthernet0/0
C       10.21.0.0/16 is directly connected, Serial2/1
R       10.33.0.0/18 [120/5] via 10.21.1.1, 00:00:03, Serial2/1
C       10.51.0.0/16 is directly connected, FastEthernet0/0
R       10.65.0.0/16 [120/1] via 10.51.1.1, 00:00:02, FastEthernet0/0
R       10.33.64.1/32 [120/5] via 10.21.1.1, 00:00:03, Serial2/1
R       10.100.0.0/16 [120/2] via 10.51.1.1, 00:00:02, FastEthernet0/0
R       10.101.0.0/16 [120/1] via 10.21.1.1, 00:00:03, Serial2/1
R*   0.0.0.0/0 [120/6] via 10.51.1.1, 00:00:02, FastEthernet0/0

R1#sh ntp s
Clock is synchronized, stratum 10, reference is 10.21.1.1
nominal freq is 250.0000 Hz, actual freq is 250.0000 Hz, precision is 2**18
reference time is CA6166E7.0C9CA258 (09:22:47.049 UTC Mon Aug 6 2007)
clock offset is 10021.8607 msec, root delay is 68.10 msec
root dispersion is 10049.29 msec, peer dispersion is 52.38 msec

R1#sh standby
FastEthernet0/0 - Group 1
State is Standby
    4 state changes, last state change 00:20:13
Virtual IP address is 10.51.1.51
Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (default)
Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.380 secs
Preemption enabled
Active router is 10.51.1.1, priority 110 (expires in 9.092 sec)
Standby router is local
Priority 100 (default 100)
IP redundancy name is "hsrp-Fa0/0-1" (default)

R2#sh run
Building configuration
...
key chain RIP_authen
key 1
key-string pass
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 137.20.20.1 255.255.255.0
duplex full
!
interface Serial2/0
ip address 10.101.1.2 255.255.0.0
ip rip advertise 5
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
no arp frame-relay
frame-relay map ip 10.101.1.3 203 broadcast
no frame-relay inverse-arp
!
interface Serial2/1
ip address 10.21.1.1 255.255.0.0
ip rip advertise 5
ip rip authentication key-chain RIP_authen
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
no arp frame-relay
frame-relay map ip 10.21.1.2 211 broadcast
no frame-relay inverse-arp
!
router ospf 1
log-adjacency-changes
redistribute rip metric 100 metric-type 1 subnets
network 10.101.1.2 0.0.0.0 area 0
neighbor 10.101.1.3
default-information originate metric 200 metric-type 1                 发布缺省路由
distance 130                                                                                  手动指定AD
distance 110 0.0.0.0 255.255.255.255 1                                   防止路由环路
!
router rip
version 2
timers basic 5 15 0 30
redistribute ospf 1 metric 5
passive-interface default                                                       
no passive-interface Serial2/1                                               只允许S2/1发送和接收RIP包
network 10.0.0.0
distance 130
distance 120 10.21.1.2 0.0.0.0 2
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 137.20.20.2
no ip http server
!
!
access-list 1 permit 10.33.0.0 0.0.255.255
access-list 1 permit 10.3.0.0 0.0.255.255
access-list 1 permit 10.6.0.0 0.0.255.255
access-list 1 permit 10.100.0.0 0.0.255.255
access-list 2 permit 10.51.0.0 0.0.255.255
access-list 2 permit 10.65.0.0 0.0.255.255
!
ntp master 9
ntp peer 10.21.1.2 source FastEthernet0/0
!
end
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 137.20.20.2 to network 0.0.0.0
     137.20.0.0/24 is subnetted, 1 subnets
C       137.20.20.0 is directly connected, FastEthernet0/0
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
O IA    10.3.0.0/16 [110/65] via 10.101.1.3, 00:27:41, Serial2/0
O E1    10.6.0.0/16 [110/228] via 10.101.1.3, 00:27:41, Serial2/0
C       10.21.0.0/16 is directly connected, Serial2/1
O IA    10.33.0.0/18 [110/65] via 10.101.1.3, 00:27:41, Serial2/0
R       10.51.0.0/16 [120/1] via 10.21.1.2, 00:00:01, Serial2/1
R       10.65.0.0/16 [120/2] via 10.21.1.2, 00:00:01, Serial2/1
O IA    10.33.64.1/32 [110/65] via 10.101.1.3, 00:27:41, Serial2/0
O       10.100.0.0/16 [110/128] via 10.101.1.3, 00:27:41, Serial2/0
C       10.101.0.0/16 is directly connected, Serial2/0
S*   0.0.0.0/0 [1/0] via 137.20.20.2
R2#sh ntp s
Clock is synchronized, stratum 9, reference is 127.127.7.1
nominal freq is 250.0000 Hz, actual freq is 250.0000 Hz, precision is 2**24
reference time is CA616777.75BFFC20 (09:25:11.459 UTC Mon Aug 6 2007)
clock offset is 0.0000 msec, root delay is 0.00 msec
root dispersion is 0.02 msec, peer dispersion is 0.02 msec
R3#sh run
Building configuration...
ip cef
frame-relay de-list 1 protocol ip list 100                   设置 匹配ACL100的包的DE位为1

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
ip address 10.33.32.1 255.255.224.0
!
interface Loopback2
ip address 10.33.64.1 255.255.224.0
!
interface FastEthernet0/0
ip address 10.3.1.1 255.255.0.0
duplex full
!
interface Serial2/0
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
no arp frame-relay
no frame-relay inverse-arp
!
interface Serial2/0.2 point-to-point
ip address 10.101.1.3 255.255.0.0
ip ospf network non-broadcast
frame-relay interface-dlci 302  
!
interface Serial2/0.6 point-to-point
ip address 10.100.1.3 255.255.0.0
ip ospf network non-broadcast
frame-relay de-group 1 306
frame-relay interface-dlci 306  
!
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
area 3 range 10.33.0.0 255.255.192.0                       area 3做路由汇总
network 10.3.1.1 0.0.0.0 area 33
network 10.33.32.1 0.0.0.0 area 3
network 10.33.64.1 0.0.0.0 area 3
network 10.100.1.3 0.0.0.0 area 0
network 10.101.1.3 0.0.0.0 area 0
neighbor 10.101.1.2
neighbor 10.100.1.6
!
ip classless
no ip http server
!
!
access-list 100 permit tcp any any
end
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.101.1.2 to network 0.0.0.0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     10.0.0.0/8 is variably subnetted, 10 subnets, 3 masks
C       10.3.0.0/16 is directly connected, FastEthernet0/0
C       10.33.32.0/19 is directly connected, Loopback1
O E1    10.6.0.0/16 [110/164] via 10.100.1.6, 00:32:35, Serial2/0.6
O E1    10.21.0.0/16 [110/164] via 10.101.1.2, 00:21:16, Serial2/0.2
                     [110/164] via 10.100.1.6, 00:21:16, Serial2/0.6
O       10.33.0.0/18 is a summary, 00:37:30, Null0
O E1    10.51.0.0/16 [110/164] via 10.100.1.6, 00:11:41, Serial2/0.6
                     [110/164] via 10.101.1.2, 00:11:41, Serial2/0.2
O E1    10.65.0.0/16 [110/164] via 10.100.1.6, 00:11:41, Serial2/0.6
                     [110/164] via 10.101.1.2, 00:11:41, Serial2/0.2
C       10.33.64.0/19 is directly connected, Loopback2
C       10.100.0.0/16 is directly connected, Serial2/0.6
C       10.101.0.0/16 is directly connected, Serial2/0.2
O*E1 0.0.0.0/0 [110/264] via 10.101.1.2, 00:32:36, Serial2/0.2
R5#sh run
Building configuration...
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
ip address 10.51.1.1 255.255.0.0
ip rip advertise 5
duplex full
standby 1 ip 10.51.1.51
standby 1 priority 110
standby 1 preempt
!        
!
interface Serial2/1
ip address 10.65.1.2 255.255.0.0
ip rip advertise 5
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
no arp frame-relay
frame-relay map ip 10.65.1.1 516 broadcast
no frame-relay inverse-arp
!
router rip
version 2
timers basic 5 15 0 30
network 10.0.0.0
no auto-summary
!
!
end
R5# sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.65.1.1 to network 0.0.0.0
     5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected, Loopback0
     10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
R       10.3.0.0/16 [120/5] via 10.65.1.1, 00:00:02, Serial2/1
R       10.6.0.0/16 [120/1] via 10.65.1.1, 00:00:02, Serial2/1
R       10.21.0.0/16 [120/1] via 10.51.1.2, 00:00:00, FastEthernet0/0
R       10.33.0.0/18 [120/5] via 10.65.1.1, 00:00:02, Serial2/1
C       10.51.0.0/16 is directly connected, FastEthernet0/0
C       10.65.0.0/16 is directly connected, Serial2/1
R       10.33.64.1/32 [120/5] via 10.65.1.1, 00:00:02, Serial2/1
R       10.100.0.0/16 [120/1] via 10.65.1.1, 00:00:02, Serial2/1
R       10.101.0.0/16 [120/2] via 10.51.1.2, 00:00:00, FastEthernet0/0
R*   0.0.0.0/0 [120/5] via 10.65.1.1, 00:00:02, Serial2/1
R5#sh stand
FastEthernet0/0 - Group 1
State is Active
    1 state change, last state change 00:24:21
Virtual IP address is 10.51.1.51
Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (default)
Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.380 secs
Preemption enabled
Active router is local
Standby router is 10.51.1.2, priority 100 (expires in 8.712 sec)
Priority 110 (configured 110)
IP redundancy name is "hsrp-Fa0/0-1" (default)
R6#sh run
Building configuration...
interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
ip address 10.6.1.1 255.255.0.0
ip rip advertise 5
duplex full
!
interface Serial2/0
ip address 10.100.1.6 255.255.0.0
ip rip advertise 5
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
no arp frame-relay
frame-relay map ip 10.100.1.3 603 broadcast
no frame-relay inverse-arp
!
interface Serial2/1
ip address 10.65.1.1 255.255.0.0
ip rip advertise 5
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
no arp frame-relay
frame-relay map ip 10.65.1.2 615 broadcast
no frame-relay inverse-arp
!
router ospf 1
log-adjacency-changes
redistribute rip metric 100 metric-type 1 subnets
network 10.100.1.6 0.0.0.0 area 0
neighbor 10.100.1.3
distance 130
distance 110 0.0.0.0 255.255.255.255 1
!
router rip
version 2
timers basic 5 15 0 30
redistribute ospf 1 metric 5
passive-interface default
no passive-interface Serial2/1
network 10.0.0.0
distance 130
distance 120 10.65.1.2 0.0.0.0 2
no auto-summary
!
ip classless
no ip http server
!
!
access-list 1 permit 10.3.0.0 0.0.255.255
access-list 1 permit 10.33.0.0 0.0.255.255
access-list 1 permit 10.101.0.0 0.0.255.255
access-list 1 permit 137.20.20.0 0.0.0.255
access-list 2 permit 10.51.0.0 0.0.255.255
access-list 2 permit 10.21.0.0 0.0.255.255
!
end
R6#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.100.1.3 to network 0.0.0.0
     6.0.0.0/32 is subnetted, 1 subnets
C       6.6.6.6 is directly connected, Loopback0
     10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
O IA    10.3.0.0/16 [110/65] via 10.100.1.3, 00:30:13, Serial2/0
C       10.6.0.0/16 is directly connected, FastEthernet0/0
R       10.21.0.0/16 [120/2] via 10.65.1.2, 00:00:03, Serial2/1
O IA    10.33.0.0/18 [110/65] via 10.100.1.3, 00:30:13, Serial2/0
R       10.51.0.0/16 [120/1] via 10.65.1.2, 00:00:03, Serial2/1
C       10.65.0.0/16 is directly connected, Serial2/1
O IA    10.33.64.1/32 [110/65] via 10.100.1.3, 00:30:13, Serial2/0
C       10.100.0.0/16 is directly connected, Serial2/0
O       10.101.0.0/16 [110/128] via 10.100.1.3, 00:30:13, Serial2/0
O*E1 0.0.0.0/0 [130/328] via 10.100.1.3, 00:30:13, Serial2/0
R6#

VLAN环境
SW1#sh vlan-s b
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/0, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa1/0, Fa1/1
                                                Fa1/2, Fa1/3, Fa1/4, Fa1/5
                                                Fa1/6, Fa1/7, Fa1/8, Fa1/9
                                                Fa1/10, Fa1/11, Fa1/12, Fa1/13
                                                Fa1/14, Fa1/15
10   VLAN0010                         active    Fa0/1, Fa0/4, Fa0/5
20   VLAN0020                         active    Fa0/2
30   VLAN0030                         active    Fa0/3
60   VLAN0060                         active    Fa0/6
1002 fddi-default                     active   
1003 token-ring-default               active   
1004 fddinet-default                  active   
1005 trnet-default                    active