HUST 1010 The Minimum Length (KMP 最短循环节)

Description

There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA...... Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the shortest possible string A. For example, A="abcdefg". I got abcd efgabcdefgabcdefgabcdefg.... Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A.

Input

Multiply Test Cases. For each line there is a string B which contains only lowercase and uppercase charactors. The length of B is no more than 1,000,000.

Output

For each line, output an integer, as described above.

Sample Input

bcabcab
efgabcdefgabcde

Sample Output

3
7
#include <stdio.h>
#include <string.h>
using namespace std;
const int maxn=1000010;
char t[maxn];
int n[maxn];
int len;
void get_next()
{
    int i=0;
    int j=-1;
    n[0]=-1;
    while(i<len)
    {
        if(j==-1||t[i]==t[j])
        {
            i++;
            j++;
            n[i]=j;
        }
        else
            j=n[j];
    }
}
int main()
{
    while(scanf("%s",t)!=EOF)
    {
        int j,i;
        len=strlen(t);
        memset(n,0,sizeof(n));
        get_next();
       printf("%d\n",len-n[len]);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/tianmin123/p/4666863.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值