The Minimum Length KMP

The Minimum Length
Time Limit:1000MS     Memory Limit:131072KB     64bit IO Format:%lld & %llu

Description

There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA...... Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the shortest possible string A. For example, A="abcdefg". I got abcd  efgabcdefgabcdefgabcdefg.... Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A.

Input

Multiply Test Cases. For each line there is a string B which contains only lowercase and uppercase charactors. The length of B is no more than 1,000,000.

Output

For each line, output an integer, as described above.

Sample Input

bcabcab
efgabcdefgabcde

Sample Output

3
7

题意:

给出一个长度为n的字符串s,该字符串是某个字符串s1重复若干次后所得字符串ns1的一个子串,问s1的最小长度是多少


思路 :

可将给出的s看成s1的末尾部分,这是因为,ns1是有s1重复若干次的来的,可将ns1的末尾某些字符移到首部,使得s1是ns1的后缀,而进行移动后,ns1仍然是由某个字符串s2重复同样次数得来的。


于是维护出KMP的next数组,设la=next[n-1]+1,则需要在s前添补n-la个字符串就能使得s是由s以la为起始的后缀重复两次得来的。


#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>

using namespace std;

#define INF 1000000000
#define N 1000010
int n, nxt[N];
char str[N];

void getNext()
{
    nxt[0] = -1;
    for(int i = 1; i < n; i++)
    {
        int p = nxt[i-1];

        for(; p != -1 && str[p+1] != str[i]; p = nxt[p]);

        p = str[p+1] == str[i] ? p+1 : -1;

        nxt[i] = p;
    }
}

int main()
{
    //freopen("C:\\Users\\zfh\\Desktop\\in.txt", "r", stdin);
    while(scanf(" %s", str) != -1)
    {
        n = strlen(str);
        getNext();
        int ans;

        int la = nxt[n-1]+1;
        ans = n-la;

        printf("%d\n", ans);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值