HDU-1800 Flying to the Mars

Flying to the Mars

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3572    Accepted Submission(s): 1129


Problem Description
1800-1.jpg

In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example :  
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed.  
 

Input
Input file contains multiple test cases.  
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
 

Output
For each case, output the minimum number of broomsticks on a single line.
 

Sample Input
 
  
4 10 20 30 04 5 2 3 4 3 4
 

Sample Output
 
  
1 2
 

  这道题的意思是说  一群人学习一项技能,水平高的可以带水平低的, 由于一起学习可以使用同一套设备,所以我们的目的是计算能够分出的最少组数。   还记得以前做过一道类似的题目,那时候使用字典树来做,但是后来听小白讲题中所求的设备数是有相同的权值的点的最可个数决定的, 如 1、2、2、2、3 最后的结果就是3 , 这样的话,题目就异常简单了,当然这只是法一:

代码如下:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

int T;

int num[3005];

int cmp( const void *a, const void *b )
{
	return *( int * )b- *( int * )a;
}

int in(  )
{
    int num; char x;
    x= getchar(  );
    if( x== EOF ) 
        return false;
    while( x> '9'|| x< '0' ) 
        x= getchar(  );
    num= x- '0';
    while( x= getchar(  ), x>= '0'&& x<= '9' )
        num= num* 10+ x- '0';
    return num;
}

int main(  )
{
	int N;
	while( ~scanf( "%d", &N ) )
	{
        getchar(  );
		int max= 0, cnt= 1;
		for( int i= 0; i< N; ++i )
		{
            num[ i ]= in(  );
		}
		if( N==0|| ++max,N==1 )
		{
			printf( "%d\n", max );
			continue;
		}
		qsort( num, N, sizeof( num[0] ), cmp  );
		for(int i= 1; i< N; ++i)
		{
            if( num[i- 1]== num[i] )
            {
                cnt++;
                if( cnt> max )
                    max= cnt;
            }
            else
                cnt= 1;
        }
        printf( "%d\n", max );
	}
}

接下来是网上的hash 做法:

#include <stdio.h>
#include <memory.h>

#define MAXN 10000
inline int ELFhash(char *key) // 表示不懂
{
    unsigned long h = 0;
    unsigned long g;
    while( *key )
    {
        h =( h<< 4) + *key++;
        g = h & 0xf0000000L;
        if( g ) h ^= g >> 24;
        h &= ~g;
    }
    return h;
}
int hash[MAXN],count[MAXN];
int maxit,n;
inline void hashit(char *str)
{
    int k,t;
    while( *str == '0' )    str++;
    k = ELFhash(str);
    t = k % MAXN;
    while( hash[t] != k && hash[t] != -1 )
        t = ( t + 5 ) % MAXN;
    if( hash[t] == -1 )    
        count[t] = 1,hash[t] = k;
    else if( ++count[t] > maxit ) 
        maxit = count[t];
}
int main()
{
    char str[100];
    while(scanf("%d",&n)!=EOF)
    {
        memset(hash,-1,sizeof(hash));
        for(maxit=1,gets(str);n>0;n--)
        {
            gets(str);
            hashit(str);
        }
        printf("%d\n",maxit);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值