UVA - 10239 The Book-shelver's Problem

Description

Download as PDF
Problem D
The Book-shelver’s Problem

Input: standard input
Output: standard output
Time Limit: 5 seconds
Memory Limit: 32 MB

 

You are given a collection of books, which must be shelved in a library bookcase ordered (from top to bottom in the bookcase and from left to right in each shelf) by the books’ catalogue numbers. The bookcase has a fixed width, but you may have any height you like. The books are placed on shelves in the bookcase in the usual upright manner (i.e., you cannot lay a book on its side). You may use as many shelves as you like, placed wherever you like up to the height of the bookcase, and you may put as many books on each shelf as you like up to the width of the bookcase. You may assume that the shelves have negligible thickness.

 

Now, given an ordered (by catalogue numbers) list of the heights and widths of the books and the width of the bookcase, you are expected to determine what is the minimum height bookcase that can shelve all those books.

 

Input

The input file may contain multiple test cases. The first line of each test case contains an integer N (1 £ N £ 1000) that denotes the number of books to shelve, and a floating-point number W (0 < W £ 1000) that denotes the width of the bookcase in centimeters. Then follow N lines where the i-th (1 £ i £ N) line contains two floating-point numbers hi (0 < hi £ 100) and wi (0 < wi £ W) indicating the height and width (both in centimeters) of the i-th book in the list ordered by catalogue numbers. Each floating-point number will have four digits after the decimal point.

 

A test case containing two zeros for N and W terminates the input.

 

Output

For each test case in the input print a line containing the minimum height (in centimeters, up to four digits after the decimal point) of the bookcase that can shelve all the books in the list.

 

Sample Input
5 30.0000
30.0000 20.0000
20.0000 10.0000
25.0000 10.0000
30.0000 15.0000
10.0000 5.0000
10 20.0000
10.0000 2.0000
15.0000 10.0000
20.0000 5.0000
6.0000 2.0000
10.0000 3.0000
30.0000 6.0000
5.0000 3.0000
35.0000 2.0000
32.0000 4.0000
10.0000 6.0000
0 0.0000

 

Sample Output
60.0000

65.0000

题意:n本书,有宽和高,要你依次放到书架上,能够用木板隔层,每层最多不超过m的宽度

思路:居然要求是依次放,那么每本书有放这层和不放这层的两种可能,记忆化搜索,注意要考虑全都放一层的情况

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstdlib>
using namespace std;
const int maxn = 1005;
const double inf = 0x3f3f3f3f3f3f3f3f;
double m, h[maxn], w[maxn], dp[maxn];
int n, vis[maxn];

double dfs(int cur) {
	if (cur >= n+1)
		return 0;
	if (vis[cur])
		return dp[cur];
	double &ans = dp[cur];
	ans = inf;
	vis[cur] = 1;
	double H = h[cur], W = w[cur];
	for (int u = cur+1; u <= n+1; u++) {
		ans = min(ans, dfs(u)+H);
		W += w[u];
		H = max(H, h[u]);
		if (W-m > 1e-9)
			break;
	}
	return ans;
}

int main() {
	while (scanf("%d%lf", &n, &m) != EOF && n) {
		memset(vis, 0, sizeof(vis));
		for (int i = 1; i <= n; i++)
			scanf("%lf%lf", &h[i], &w[i]);
		double ans = dfs(1);
		printf("%.4lf\n", ans);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值