uva 10239 The Book-shelver's Problem (dp)

Problem D
The Book-shelver’s Problem

Input: standard input
Output: standard output
Time Limit: 5 seconds
Memory Limit: 32 MB

 

You are given a collection of books, which must be shelved in a library bookcase ordered (from top to bottom in the bookcase and from left to right in each shelf) by the books’ catalogue numbers. The bookcase has a fixed width, but you may have any height you like. The books are placed on shelves in the bookcase in the usual upright manner (i.e., you cannot lay a book on its side). You may use as many shelves as you like, placed wherever you like up to the height of the bookcase, and you may put as many books on each shelf as you like up to the width of the bookcase. You may assume that the shelves have negligible thickness.

 

Now, given an ordered (by catalogue numbers) list of the heights and widths of the books and the width of the bookcase, you are expected to determinewhat is the minimum height bookcase that can shelve all those books.

 

Input

The input file may contain multiple test cases. The first line of each test case contains an integer N (1 £ N £ 1000) that denotes the number of books to shelve, and a floating-point number W (0 < W £ 1000) that denotes the width of the bookcase in centimeters. Then follow N lines where the i-th (1 £ i £N) line contains two floating-point numbers hi (0 < hi £ 100) and wi (0 < wi £ W) indicating the height and width (both in centimeters) of the i-th book in the list ordered by catalogue numbers. Each floating-point number will have four digits after the decimal point.

 

A test case containing two zeros for N and W terminates the input.

 

Output

For each test case in the input print a line containing the minimum height (in centimeters, up to four digits after the decimal point) of the bookcase that can shelve all the books in the list.

 

Sample Input
5 30.0000
30.0000 20.0000
20.0000 10.0000
25.0000 10.0000
30.0000 15.0000
10.0000 5.0000
10 20.0000
10.0000 2.0000
15.0000 10.0000
20.0000 5.0000
6.0000 2.0000
10.0000 3.0000
30.0000 6.0000
5.0000 3.0000
35.0000 2.0000
32.0000 4.0000
10.0000 6.0000
0 0.0000

 

Sample Output
60.0000
65.0000

(World Finals Warm-up Contest, Problem setter: Rezaul Alam Chowdhury)

 

"Even the darkest clowd has a silver lining."


这道题不错!开始想的状态是dp[i][j]表示放第i个时,这一行还有j的宽度,放完前i个的最小值。然后因为这题宽度是浮点数,所以没办法做了,把宽度扩大10000倍就超时。搜了下题解发现别人直接用dp[i]表示把第i个放在这一行的第一个时,把后面全部放完的最小代价。这样,考虑放完第i个后,后面接着放在这一行的,所有放法的可能性做转移。

#include<cstdio>
#include<map>
#include<queue>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<list>
#include<set>
#include<cmath>
using namespace std;
const int maxn = 1000 + 5;
const int INF = 1e9;
const double eps = 1e-6;
typedef unsigned long long ULL;
typedef long long LL;
typedef pair<int, int> P;
#define fi first
#define se second

double dp[maxn];
double h[maxn], w[maxn];
int n, get[maxn];
double width;

double dfs(int cur){
    if(get[cur])
        return dp[cur];
    if(cur >= n)
        return 0;
    if(cur == n-1)
        return h[n-1];
    get[cur] = 1;
    double ret = (double)INF;
    double height = h[cur], wid = w[cur];
    for(int i = cur+1;i <= n;i++){
        ret = min(ret, dfs(i)+height);
        height = max(height, h[i]);
        wid += w[i];
        if(wid-width>eps)
            break;
    }
    return dp[cur] = ret;
}

int main(){
    while(cin >> n >> width){
        if(n == 0 && width < eps)
            break;
        for(int i = 0;i < n;i++){
            cin >> h[i] >> w[i];
        }
        memset(get, 0, sizeof get);
        printf("%.4lf\n", dfs(0));
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值