南阳OJ----Binary String Matching

Binary String Matching

时间限制: 3000  ms  |  内存限制: 65535  KB
难度: 3
 
描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
 
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011 
样例输出
3
0
3 
来源
网络
上传者
naonao
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
typedef struct node
{
  char a;
  struct node *next;
}Node;
int i;
bool flag=true;
int main( void )
{
    Node *head,*p1,*p2;
    int t,n,count;
    scanf("%d",&t);
    getchar();
    while(t--)
    {
        head=NULL;
        count=n=0;
        p1=p2=( Node * )malloc( sizeof(Node) );
        char str[10]={'\0'};
        gets(str);
        //getchar();
        while(p1->a=getchar(),p1->a!='\n')
        {
            if(n++==0)
                      head=p1;
            else 
                 p2->next=p1;
                 p2=p1;
            p1=(Node*)malloc(sizeof(Node));
        }
        p2->next=NULL;
          p1=head;
    /*      while(p1!=NULL)
          {
              putchar(p1->a);
              p1=p1->next;
          }
          puts("");
    */
         while(p1!=NULL)
         {
         
              while(p1!=NULL&&p1->a!=*str)   //找到第一个位置
                 {
                   p1=p1->next;
                 }
              if(p1!=NULL)                //防止万一没有找到
              {
                  p2=p1->next;

                for( ::i=0; str[i]!='\0'; i++ )
                {
                  if(str[i]==p1->a)
                  {
                      p1=p1->next;
                  }
                  else 
                  {
                      ::flag=false;
                           p1=p2;
                             break;
                  }
                  
                  if((p1==NULL&&str[i+1]!='\0'))
                      {
                         ::flag=false ;
                          break;
                      }
                }
                    
                 if(::flag)
                 {
                          p1=p2 ;
                          count++;
                 }
                else 
                    ::flag=true;
              }
            }

         free(head);
         printf("%d\n",count);
        
         }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
SDUT-OJ(Software Development University of Tsinghua Online Judge)是一个在线编程平台,提供给清华大学软件学院的学生和爱好者练习和解决算法问题的环境,其中包括各种计算机科学题目,包括数据结构、算法、图形等。对于"最小生成树"(Minimum Spanning Tree, MST)问题,它是图论中的经典问题,目标是从一个加权无向图中找到一棵包含所有顶点的树,使得树的所有边的权重之和最小。 在C语言中,最常见的是使用Prim算法或Kruskal算法来求解最小生成树。Prim算法从一个顶点开始,逐步添加与当前生成树相连且权重最小的边,直到所有顶点都被包含;而Kruskal算法则是从小到大对所有边排序,每次选取没有形成环的新边加入到树中。 如果你想了解如何用C语言实现这些算法,这里简单概括一下: - 通常使用优先队列(堆)来存储边和它们的权重,以便快速查找最小值。 - 从任意一个顶点开始,遍历与其相邻的边,若新边不形成环,就更新树,并将新边加入优先队列。 - Kruskal算法: - 先将所有的边按照权重升序排序。 - 创建一个空的最小生成树,然后依次取出排序后的边,如果这条边连接的两个顶点不在同一个连通分量,则将其添加到树中。 如果你需要更详细的代码示例,或者有具体的问题想了解(比如如何处理环、如何实现优先队列等),请告诉我,我会为你提供相应的帮助。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值