HDU 5095 Linearization of the kernel functions in SVM(模拟)

主题链接:http://acm.hdu.edu.cn/showproblem.php?

pid=5095


Problem Description
SVM(Support Vector Machine)is an important classification tool, which has a wide range of applications in cluster analysis, community division and so on. SVM The kernel functions used in SVM have many forms. Here we only discuss the function of the form f(x,y,z) = ax^2 + by^2 + cz^2 + dxy + eyz + fzx + gx + hy + iz + j. By introducing new variables p, q, r, u, v, w, the linearization of the function f(x,y,z) is realized by setting the correspondence x^2  <-> p, y^2  <-> q, z^2  <-> r, xy  <-> u, yz  <-> v, zx  <-> w and the function f(x,y,z) = ax^2 + by^2 + cz^2 + dxy + eyz + fzx + gx + hy + iz + j can be written as g(p,q,r,u,v,w,x,y,z) = ap + bq + cr + du + ev + fw + gx + hy + iz + j, which is a linear function with 9 variables.

Now your task is to write a program to change f into g.
 

Input
The input of the first line is an integer T, which is the number of test data (T<120). Then T data follows. For each data, there are 10 integer numbers on one line, which are the coefficients and constant a, b, c, d, e, f, g, h, i, j of the function f(x,y,z) = ax^2 + by^2 + cz^2 + dxy + eyz + fzx + gx + hy + iz + j.
 

Output
For each input function, print its correspondent linear function with 9 variables in conventional way on one line.
 

Sample Input
 
  
2 0 46 3 4 -5 -22 -8 -32 24 27 2 31 -5 0 0 12 0 0 -49 12
 

Sample Output
 
  
46q+3r+4u-5v-22w-8x-32y+24z+27 2p+31q-5r+12w-49z+12
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5098  5097  5096  5094  5093 

PS:

一道比較坑的模拟题。

注意1和-1 的情况。


代码例如以下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
int main()
{
    int M;
    int a[17];
    char b[17] = {'#','p','q','r','u','v','w','x','y','z'};
    scanf("%d",&M);
    getchar();
    while(M--)
    {
        for(int k = 1; k <= 10; k++)
        {
            scanf("%d",&a[k]);
        }
        int cont = 0;
        int flag = 0;
        for(int k = 1; k < 10; k++)
        {
            if(a[k]==0)
                continue;
            cont++;
            if(cont == 1)
            {
                if(a[k] != 1 && a[k] != -1)
                    printf("%d%c",a[k],b[k]);
                else if(a[k] == 1)
                    printf("%c",b[k]);
                else if(a[k] == -1)
                    printf("-%c",b[k]);
                flag = 1;
            }
            else
            {
                if(a[k] > 0)
                    printf("+");
                if(a[k] != 1 && a[k] != -1)
                    printf("%d%c",a[k],b[k]);
                else if(a[k] == 1)
                    printf("%c",b[k]);
                else if(a[k] == -1)
                    printf("-%c",b[k]);
                flag = 1;
            }
        }
        if(a[10])
        {
            if(a[10] > 0 && flag)
                printf("+");
            printf("%d",a[10]);
            flag = 1;
        }
        if(!flag)//没有答案
            printf("0");
        printf("\n");
    }
    return 0;
}
/*
99
0 0 0 0 0 0 0 0 0 -1
0 0 0 0 0 0 0 0 0 1
0 0 0 0 0 0 0 0 0 0
1 0 0 0 0 0 0 0 0 0
-1 0 0 0 0 0 0 0 0 0
-1 -1 -1 -41 -1 -1 -1 -1 -1 -1
-1 5 -2 0 0 0 0 0 0 0
1 1 1 1 1 1 1 1 1 1
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1
0 0 0 0 0 -1 -1 -1 -1 -1
0 0 0 0 0 1 1 1 1 1
1 1 1 1 1 0 0 0 0 0
-1 -1 -1 -1 -1 0 0 0 0 0
1 1 1 1 1 1 1 1 1 0
*/


版权声明:本文博客原创文章。博客,未经同意,不得转载









本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/4723404.html,如需转载请自行联系原作者


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值