F - Linearization of the kernel functions in SVM HDU - 5095(模拟)

SVM(Support Vector Machine)is an important classification tool, which has a wide range of applications in cluster analysis, community division and so on. SVM The kernel functions used in SVM have many forms. Here we only discuss the function of the form f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j. By introducing new variables p, q, r, u, v, w, the linearization of the function f(x,y,z) is realized by setting the correspondence x^2 <-> p, y^2 <-> q, z^2 <-> r, xy <-> u, yz <-> v, zx <-> w and the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j can be written as g(p,q,r,u,v,w,x,y,z) = ap + bq + cr + du + ev + fw + gx + hy + iz + j, which is a linear function with 9 variables.

Now your task is to write a program to change f into g.

Input

The input of the first line is an integer T, which is the number of test data (T<120). Then T data follows. For each data, there are 10 integer numbers on one line, which are the coefficients and constant a, b, c, d, e, f, g, h, i, j of the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j.

Output

For each input function, print its correspondent linear function with 9 variables in conventional way on one line.

Sample Input

2
0 46 3 4 -5 -22 -8 -32 24 27
2 31 -5 0 0 12 0 0 -49 12

Sample Output

46q+3r+4u-5v-22w-8x-32y+24z+27
2p+31q-5r+12w-49z+12

题意:将f(x,y,z) = ax^2 + by^2 + cz^2 + dxy + eyz + fzx + gx + hy + iz + j.    注意:下划线部分题目给的试子有点错误

 转化成             g =ap    +  bq   +    cr   +  du +  ev  + fw  + gx +hy  + iz + j

思路:这道题坑有点多~~,交了6发在才过去,都开始怀疑自己是不是看错题了~~

          1.  注意当系数为1时,不显示1,如 p+q+3

          2.  注意当系数为-1时,只显示负号,不显示,如p-q

          3.  当为常数项时,显示数字,如0 ,  -2  ,5

          4.  系数为0的项不显示

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char str[]="pqruvwxyz";
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		int flag=0;
		int x;
		for(int i=0;i<9;i++){
			scanf("%d",&x);
			if(x>0){
				if(flag) printf("+");
				if(x>1)printf("%d",x);
				flag=1;
			}
			else if(x<0){
				if(x==-1) printf("-");
				else printf("%d",x);
				flag=1;
			}
			if(x) printf("%c",str[i]);
		}
		scanf("%d",&x);
		if(!flag) printf("%d",x);
		else if(x>0) printf("+%d",x);
		else if(x<0) printf("%d",x);
		puts("");
	}
	return 0;
}

      

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值