POJ 1775 Sum of Factorials

 Sum of Factorials
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

Description

John von Neumann, b. Dec. 28, 1903, d. Feb. 8, 1957, was a Hungarian-American mathematician who made important contributions to the foundations of mathematics, logic, quantum physics,meteorology, science, computers, and game theory. He was noted for a phenomenal memory and the speed with which he absorbed ideas and solved problems. In 1925 he received a B.S. diploma in chemical engineering from Zurich Institute and in 1926 a Ph.D. in mathematics from the University of Budapest. His Ph.D. dissertation on set theory was an important contribution to the subject. At the age of 20, von Neumann proposed a new definition of ordinal numbers that was universally adopted. While still in his twenties, he made many contributions in both pure and applied mathematics that established him as a mathematician of unusual depth. His Mathematical Foundations of Quantum Mechanics (1932) built a solid framework for the new scientific discipline. During this time he also proved the mini-max theorem of GAME THEORY. He gradually expanded his work in game theory, and with coauthor Oskar Morgenstern he wrote Theory of Games and Economic Behavior (1944). 
There are some numbers which can be expressed by the sum of factorials. For example 9,9=1!+2!+3! Dr. von Neumann was very interested in such numbers. So, he gives you a number n, and wants you to tell him whether or not the number can be expressed by the sum of some factorials. 
Well, it's just a piece of cake. For a given n, you'll check if there are some xi, and let n equal to Σ 1<=i<=tx i!. (t >=1 1, xi >= 0, xi = xj iff. i = j). If the answer is yes, say "YES"; otherwise, print out "NO".

Input

You will get several non-negative integer n (n <= 1,000,000) from input file. Each one is in a line by itself. 
The input is terminated by a line with a negative integer.

Output

For each n, you should print exactly one word ("YES" or "NO") in a single line. No extra spaces are allowed.

Sample Input

9
-1

Sample Output

YES

#include <stdio.h>
#include <string.h>

bool flag=0;
int t[11]; 

void dfs(int sum, int k, int ans){
     if(k>10 || ans>sum)
         return ;
     if(sum==ans){
         printf("YES\n");
         flag=true;
         return;
     }
     if(!flag)
         dfs(sum,k+1,ans+t[k]);
     if(!flag)
         dfs(sum,k+1,ans); 
}

int main(){
    int sum;
    t[0]=1;
    t[1]=1;
    for(int i=2; i<=10; i++)
        t[i]=t[i-1]*i;

    while(scanf("%d",&sum)&&sum>=0){
        flag=false;
        if(sum==0)printf("NO\n");
        else{
            dfs(sum,0,0);
            if(!flag)
                puts("NO");
        }
    }
    return 0;
}

dfs解決這個問題 ,第一次自己寫dfs遞歸搜索,還不錯感覺,應該是思路清晰的解決問題



转载于:https://my.oschina.net/dianpaopao/blog/75926

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值