1586:Molar mass

An organic compound is any member of a large class of chemicalcompounds whose molecules contain carbon. The molarmass of an organic compound is the mass of one mole of theorganic compound. The molar mass of an organic compoundcan be computed from the standard atomic weights of theelements.

  When an organic compound is given as a molecular formula,Dr. CHON wants to find its molar mass. A molecularformula, such as C3H4O3, identifies each constituent element byits chemical symbol and indicates the number of atoms of eachelement found in each discrete molecule of that compound. Ifa molecule contains more than one atom of a particular element,this quantity is indicated using a subscript after the chemical symbol.

  In this problem, we assume that the molecular formula is represented by only four elements, ‘C’(Carbon), ‘H’ (Hydrogen), ‘O’ (Oxygen), and ‘N’ (Nitrogen) without parentheses.

  The following table shows that the standard atomic weights for ‘C’, ‘H’, ‘O’, and ‘N’.


  For example, the molar mass of a molecular formula C6H5OH is 94.108 g/mol which is computed by6 × (12.01 g/mol) + 6 × (1.008 g/mol) + 1 × (16.00 g/mol).

  Given a molecular formula, write a program to compute the molar mass of the formula.

Input

Your program is to read from standard input. The input consists of T test cases. The number of testcases T is given in the first line of the input. Each test case is given in a single line, which containsa molecular formula as a string. The chemical symbol is given by a capital letter and the length ofthe string is greater than 0 and less than 80. The quantity number n which is represented after thechemical symbol would be omitted when the number is 1 (2 ≤ n ≤ 99).

Output

Your program is to write to standard output. Print exactly one line for each test case. The line shouldcontain the molar mass of the given molecular formula.

Sample Input

4

CC6H5OH

NH2CH2COOH

C12H22O11

Sample Output

12.010

94.108

75.070

342.296


Regionals 2007 >> Asia - Seoul

#include<stdio.h>
#include<string.h>
#include<ctype.h>
#define maxl 80 + 5
char s[maxl];
double x[30];
int main(){
    int i,n;
    scanf("%d",&n);
    x['C' - 'A'] = 12.01;
    x['H' - 'A'] = 1.008;
    x['O' - 'A'] = 16.00;
    x['N' - 'A'] = 14.01;
    while(n--){
        memset(s,'\0',sizeof(s));
        scanf("%s",s);
        double sum = 0;
        for(i = 0;s[i];i++){
            if(s[i+1] && isdigit(s[i+1])){
                if(isdigit(s[i+2])){
                    sum += x[s[i] - 'A']*((s[i+1] - '0')*10 + (s[i+2] - '0'));
                    i += 2;
                }
                else{
                    sum += x[s[i] - 'A']*(s[i+1] - '0');
                    i++;
                }
            }
            else sum += x[s[i] - 'A'];
        }
        printf("%.3f\n",sum);
    }
    return 0;
}

转载于:https://www.cnblogs.com/JingwangLi/p/10202770.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值