ZOJ3623: Battle Ships(类完全背包)

Battle Ships

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes ti seconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

Your job is to find out the minimum time the player should spend to win the game.

Input

There are multiple test cases. 
The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers i(1 ≤ i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

Output

Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

Sample Input
1 1
1 1
2 10
1 1
2 5
3 100
1 10
3 20
10 100

Sample Output
2
4
5


Author:  FU, Yujun
Contest:  ZOJ Monthly, July 2012


dp[i]表示i时间内能制造的最大伤害,dp[i] = max( dp[i], dp[i-time[j]] + (i-time[j])*value[j] ),可以理解为dp[i-time[j]]的事件保持不变,而在事件前面增加time[j]的时间制造第j种船,该船在接下来i-time[j]时间内造成额外的伤害(i-time[j])*value[j]。

# include <stdio.h>
# include <string.h>
# define INF 0x3f3f3f3f
int dp[333], v[31],c[31];
int main()
{
    int n, t, i, j;
    while(~scanf("%d%d",&n,&t))
    {
        memset(dp, 0, sizeof(dp));
        int cnt = INF;
        for(i=0; i<n; ++i)
            scanf("%d%d",&c[i],&v[i]);
        for(i=0; i<n; ++i)
        {
            for(j=c[i]; j; ++j)
            {
                if(dp[j-c[i]]+v[i]*(j-c[i]) > dp[j])
                    dp[j] = dp[j-c[i]]+v[i]*(j-c[i]);
                if(dp[j] >= t)
                    break;
            }
            if(j < cnt)
                cnt = j;
        }
        printf("%d\n",cnt);
    }
    return 0;
}



转载于:https://www.cnblogs.com/junior19/p/6730083.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值