ZOJ 3623 Battle Ships

Battle Ships


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes ti seconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

Your job is to find out the minimum time the player should spend to win the game.

Input

There are multiple test cases.
The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers t i(1 ≤ t i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

Output

Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

Sample Input

1 1
1 1
2 10
1 1
2 5
3 100
1 10
3 20
10 100

Sample Output

2
4
5

 

题意:敌方防御塔有L的生命值,我方能建造n种飞船,建造时间为t,建造完成之后每秒能够对敌方造成l点伤害,问击败敌方最少需要多少时间。

思路:将时间作为背包容量来进行背包,那么选择一种飞船的话,就相当于在最开始的时候花了t的时间建造,之后每秒都会造成l点伤害,所以dp[j]=max(dp[j],dp[j-t[i]]+(j-t[i])*l),dp[j]表示时间为j的时候最大伤害量。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
using namespace std;
const int inf=0x3f3f3f3f;
int dp[350],c[35],w[30];
int main()
{
    int n,l,i,j;
    while(scanf("%d%d",&n,&l)!=EOF)
    {
        for(int i=1;i<=n;i++)
            scanf("%d%d",&c[i],&w[i]);
        memset(dp,0,sizeof(dp));
        int temp=inf;
        for(i=1;i<=n;i++)
        {
            for(j=c[i];j;j++)
            {
                dp[j]=max(dp[j],dp[j-c[i]]+(j-c[i])*w[i]);
                if(dp[j]>=l) break;
            }
            temp=min(temp,j);
        }
        printf("%d\n",temp);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值