poj3007

Organize Your Train part II

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 4868Accepted: 1422

Description

RJ Freight, a Japanese railroad company for freight operations has recently constructed exchange lines at Hazawa, Yokohama. The layout of the lines is shown in Figure 1.

3007_1.gif
Figure 1: Layout of the exchange lines

A freight train consists of 2 to 72 freight cars. There are 26 types of freight cars, which are denoted by 26 lowercase letters from "a" to "z". The cars of the same type are indistinguishable from each other, and each car's direction doesn't matter either. Thus, a string of lowercase letters of length 2 to 72 is sufficient to completely express the configuration of a train.

Upon arrival at the exchange lines, a train is divided into two sub-trains at an arbitrary position (prior to entering the storage lines). Each of the sub-trains may have its direction reversed (using the reversal line). Finally, the two sub-trains are connected in either order to form the final configuration. Note that the reversal operation is optional for each of the sub-trains.

For example, if the arrival configuration is "abcd", the train is split into two sub-trains of either 3:1, 2:2 or 1:3 cars. For each of the splitting, possible final configurations are as follows ("+" indicates final concatenation position):

  [3:1]
abc+d cba+d d+abc d+cba
[2:2]
ab+cd ab+dc ba+cd ba+dc cd+ab cd+ba dc+ab dc+ba
[1:3]
a+bcd a+dcb bcd+a dcb+a

Excluding duplicates, 12 distinct configurations are possible.

Given an arrival configuration, answer the number of distinct configurations which can be constructed using the exchange lines described above.

Input

The entire input looks like the following.

the number of datasets = m
1st dataset 
2nd dataset 
... 
m-th dataset

Each dataset represents an arriving train, and is a string of 2 to 72 lowercase letters in an input line.

Output

For each dataset, output the number of possible train configurations in a line. No other characters should appear in the output.

Sample Input

4
aa
abba
abcd
abcde

Sample Output

1
6
12
18

Source


 
本来以为用STL,超时了,不过熟悉STL的用法。网上查了查,用hash,看了个常用的字符串hash函数
#include <cstdio>
#include <cstring>

using  namespace std;

const int MC=9461;

struct node
{
    char str[100];
    node *next;
} *all[10000];
char s[100],r1[100],r2[100],t1[100],t2[100];
int ans;

void hash(char *str1,char *str2)
{
    char str[100],*strm;
    strcpy(str,str1);
    strcat(str,str2);
    unsigned int hash = 0;
    unsigned int x    = 0;

    strm=str;
    while (*strm)
    {
        hash = (hash << 4) + *strm;
        strm++;
        if ((x = hash & 0xF0000000L) != 0)
        {
            hash ^= (x >> 24);
            hash &= ~x;
        }
    }

    int t=(hash & 0x7FFFFFFF)%MC;
    node *p,*q;
    for ( p=q=all[t]; p&&strcmp(str,p->str); q=p,p=p->next);
        if (p)
            return;
    ans++;
    if (p==all[t])
    {
        all[t]=new node;
        p=all[t];
    }
    else
    {
        q->next=new node;
        p=q->next;
    }
    p->next=NULL;
    strcpy(p->str,str);
}

int main(void)
{
    int cas,i,j;

    scanf("%d",&cas);
    while (cas--)
    {
        memset(all,0,sizeof(all));
        ans=0;
        scanf("%s",s);
        int len=strlen(s);
        for (i=0; i<len; i++)
        {
            for (j=0; j<i; j++)
                r1[j]=s[j];
            r1[j]='\0';
            for (j=i; s[j]; j++)
                t1[j-i]=s[j];
            t1[j-i]='\0';
            for (j=i-1; j>=0; j--)
                r2[i-1-j]=s[j];
            r2[i-1-j]='\0';
            for (j=len-1; j>=i; j--)
                t2[len-1-j]=s[j];
            t2[len-1-j]='\0';
            hash(r1,t1);
            hash(t1,r1);
            hash(r1,t2);
            hash(t2,r1);
            hash(r2,t1);
            hash(t1,r2);
            hash(r2,t2);
            hash(t2,r2);
        }
        printf("%d\n",ans);
    }
    return 0;
}

转载于:https://www.cnblogs.com/eric-blog/archive/2011/05/26/2059249.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值