POJ3625 Building Roads

Building Roads
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11277 Accepted: 3208
Description

Farmer John had just acquired several new farms! He wants to connect the farms with roads so that he can travel from any farm to any other farm via a sequence of roads; roads already connect some of the farms.

Each of the N (1 ≤ N ≤ 1,000) farms (conveniently numbered 1..N) is represented by a position (Xi, Yi) on the plane (0 ≤ Xi ≤ 1,000,000; 0 ≤ Yi ≤ 1,000,000). Given the preexisting M roads (1 ≤ M ≤ 1,000) as pairs of connected farms, help Farmer John determine the smallest length of additional roads he must build to connect all his farms.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2..N+1: Two space-separated integers: Xi and Yi
  • Lines N+2..N+M+2: Two space-separated integers: i and j, indicating that there is already a road connecting the farm i and farm j.

Output

  • Line 1: Smallest length of additional roads required to connect all farms, printed without rounding to two decimal places. Be sure to calculate distances as 64-bit floating point numbers.

Sample Input

4 1
1 1
3 1
2 3
4 3
1 4
Sample Output

4.00
题意:给出n个农场,有的已经连接好了,求没连接好的农场的路的最小值;
先给出你n,m;表示下n行n个农场的坐标;
n行后再给出m行表示连接好的农场;
做这道题学到了很多,哈哈哈哈;
也有很多要注意,
1.c++用%lf,G++用%f,输出;
2.输入时注意数据类型;

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<math.h>
#include<algorithm>
using namespace std;
const int maxn=1005;
int f[maxn],len,x[maxn],y[maxn],n,m;
struct node
{
    int u,v;
    double w;
} num[1000000];
int cmp(node x,node y)
{
    return x.w<y.w;
}
int find(int u)
{
    if(f[u]==u)
        return u;
    else
    {
        f[u]=find(f[u]);
        return f[u];
    }
}
void mer(int u,int v)
{
    int t1=find(u),t2=find(v);
    if(t1!=t2)
    {
        f[t1]=t2;
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        int cou=0;
        len=1;
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&x[i],&y[i]);//上面是int
            for(int j=1; j<i; j++)
            {
                //int转化为double型
                double point=sqrt((double)(x[i]-x[j])*(x[i]-x[j])+(double)(y[i]-y[j])*(y[i]-y[j]));
                num[len].u=i;
                num[len].v=j;
                num[len++].w=point;
            }
        }
        for(int i=1; i<=n; i++)
        {
            f[i]=i;
        }
        for(int i=1; i<=m; i++)
        {
            cou++;
            int a,b;
            scanf("%d%d",&a,&b);
            mer(a,b);
        }
        sort(num,num+len,cmp);
        double sum=0;
        for(int i=1; i<=len&&cou!=n-1; i++)
        {
            if(find(num[i].u)!=find(num[i].v))
            {
                mer(num[i].u,num[i].v);
                cou++;
                sum+=num[i].w;
            }
        }
        printf("%.2f\n",sum);
        //c++用%lf,G++用%f,输出
        //这道题用c++交会超时;
    }
    return 0;
}

转载于:https://www.cnblogs.com/zxy160/p/7215153.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值