单调递增最长子序列

单调递增最长子序列

描述

求一个字符串的最长递增子序列的长度 如:dabdbf最长递增子序列就是abdf,长度为4

 

 

输入
第一行一个整数0<n<20,表示有n个字符串要处理 随后的n行,每行有一个字符串,该字符串的长度不会超过10000
输出
输出字符串的最长递增子序列的长度
样例输入
3
aaa
ababc
abklmncdefg
样例输出
1
3
7

 

 
#include <iostream>
#include <iomanip>
#include <algorithm>
#include <vector>
#include <list>
#include <memory.h>
#include <string>
#include <math.h>
using namespace std;
char ch[10005];
int dis[10005];
int main()
{
    int n;
    cin>>n;
    while(n--)
    {
        cin>>ch;
        dis[0] = 1;
        int max_ = 1;
        for(int i=0;i<strlen(ch);i++)
        {
            dis[i] = 1;
            for(int j=0;j<i;j++)
            {
                if(ch[j] < ch[i])
                    dis[i] = max(dis[i],dis[j]+1);
                if(dis[i] >= max_)
                    max_ = dis[i];
            }
        }
        
        cout<<max_<<endl;
    }

     return 0;

}

            

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值