Fang Fang

 

Problem Description
Fang Fang says she wants to be remembered.
I promise her. We define the sequence  F of strings.
F0 = f",
F1 = ff",
F2 = cff",
Fn = Fn1 + f", for n > 2
Write down a serenade as a lowercase string S in a circle, in a loop that never ends.
Spell the serenade using the minimum number of strings in F, or nothing could be done but put her away in cold wilderness.
 

 

Input
An positive integer  T, indicating there are T test cases.
Following are T lines, each line contains an string S as introduced above.
The total length of strings for all test cases would not be larger than 106.
 

 

Output
The output contains exactly  T lines.
For each test case, if one can not spell the serenade by using the strings in F, output 1. Otherwise, output the minimum number of strings in F to split S according to aforementioned rules. Repetitive strings should be counted repeatedly.
 

 

Sample Input

8
ffcfffcffcff
cffcfff
cffcff
cffcf
ffffcffcfff
cffcfffcffffcfffff
cff
cffc

Sample Output
Case #1: 3
Case #2: 2
Case #3: 2
Case #4: -1
Case #5: 2
Case #6: 4
Case #7: 1
Case #8: -1
Hint

Shift the string in the first test case, we will get the string "cffffcfffcff"
and it can be split into "cffff", "cfff" and "cff".

#include <cstdio>
#include <queue>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
const int oo = 1e9;
const int N = 1e6+8;
const int M = 6000;
typedef long long LL;
char str[N];
int vis[N];
int main()
{
    int T, ok, i, isc, n, first, xx=1, last;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%s", str);
        n = strlen(str);
        ok = 1;
        isc = 0;
        memset(vis, 0, sizeof(vis));
        first = last = -1;
        for(i = 0; i < n; i++)
        {
            if(str[i] != 'f' && str[i] != 'c')
            {
                ok = 0;
                break;
            }
            if(str[i] == 'c')
            {
                vis[i] = 1;
                last = i;
                if(isc == 0)
                    first = i;
                isc ++;
            }
        }
        if(ok == 0)
        {
            printf("Case #%d: -1\n", xx++);
            continue;
        }

        if(isc == 0)
        {
            printf("Case #%d: %d\n", xx++, (n+1)/2);
            continue;
        }

        if(isc > 0)
        {
            if(n-1-last+first < 2) ok = 0;
        }

        if(isc > 0 && ok)
        {
            for(i = first+1; i <= last; i++)
            {
                if(vis[i])
                {
                    if(i-first-1 < 2)
                        ok = 0;
                    first = i;
                }
                if(ok == 0)break;
            }
        }

        if(ok == 0) printf("Case #%d: -1\n", xx++);

        else printf("Case #%d: %d\n", xx++, isc);
    }
    return 0;
}

  

转载于:https://www.cnblogs.com/PersistFaith/p/4821908.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值