HDU 5455 Fang Fang (水题 模拟)

37 篇文章 0 订阅

Fang Fang

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 305    Accepted Submission(s): 131



Problem Description
Fang Fang says she wants to be remembered.
I promise her. We define the sequence F of strings.
F0 = "f"
F1 = "ff"
F2 = "cff"
Fn = Fn-1 + 'f', for n > 2
Write down a serenade as a lowercase string S in a circle, in a loop that never ends.
Spell the serenade using the minimum number of strings in F , or nothing could be done but put her away in cold wilderness.
 
Input
An positive integer T , indicating there are T test cases.
Following are T lines, each line contains an string S as introduced above.
The total length of strings for all test cases would not be larger than 106 .
 
Output
The output contains exactly T lines.
For each test case, if one can not spell the serenade by using the strings in F , output 1 . Otherwise, output the minimum number of strings in F to split S according to aforementioned rules. Repetitive strings should be counted repeatedly.
 
Sample Input
  
  
8 ffcfffcffcff cffcfff cffcff cffcf ffffcffcfff cffcfffcffffcfffff cff cffc
 
Sample Output
  
  
Case #1: 3 Case #2: 2 Case #3: 2 Case #4: -1 Case #5: 2 Case #6: 4 Case #7: 1 Case #8: -1
Hint
Shift the string in the first test case, we will get the string "cffffcfffcff" and it can be split into "cffff", "cfff" and "cff".
 
Source
 

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5455

题目大意:给一个字符串,可以旋转,求某个状态使得该状态下的字符串可由最少的F数组的元素构成

题目分析:先计算第一个c之前和最后一个c之后有多少f,中间任意两个c之间的f数必须大于1否则退出,然后判最后一个c的后面有几个f,因为可旋转,要加上第一个c前面的f个数,看是不是大于1,注意若全是f则答案为除2加模2,还有就是输出的字符串可能还有别的字母


#include <cstdio>
#include <cstring>
int const MAX = 1e6 + 5;
char s[MAX];

int main()
{
    int T;
    scanf("%d", &T);
    for(int ca = 1; ca <= T; ca++)
    {   
        scanf("%s", s);
        int len = strlen(s);
        bool ff = false;
        for(int i = 0; i < len; i++)
        {
            if(s[i] != 'f' && s[i] != 'c')
            {
                printf("Case #%d: -1\n", ca);
                ff = true;
                break;
            }
        }
        if(ff)
            continue;
        int ans = 0;
        bool f = true;
        int fir = 0;
        while(s[fir] == 'f')
            fir ++;
        int sec = len - 1;
        while(s[sec] == 'f')
            sec --;
        bool isc = false;
        for(int i = fir; i < len; )
        {
            if(s[i] == 'c')
            {
                isc = true;
                ans ++;
                i ++;
                int cnt = 0;
                while(s[i] == 'f')
                {
                    cnt ++;
                    i ++;
                }   
                if(cnt < 2)
                    f = false;
                if(i > sec && fir + len - sec - 1 >= 2)
                    f = true;
                if(!f)
                    break;
            }
        }
        if(!f)
            ans = -1;
        if(isc == false)
        {
            if(len % 2)
                ans = len / 2 + 1;
            else
                ans = len / 2;
        }
        printf("Case #%d: %d\n", ca, ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值