FANG FANG

Fang Fang says she wants to be remembered. I promise her. We define the sequence F of strings.
F0 = “f”,
F1 = “ff”,
F2 = “cff”,
Fn = Fn−1 + “f”, for n > 2
Write down a serenade as a lowercase string S in a circle, in a loop that never ends. Spell the serenade using the minimum number of strings in F,or nothing could be done but put her away in cold wilderness.

 

输入

An positive integer T, indicating there are T test cases. Following are T lines, each line contains an string S as introduced above. The total length of strings for all test cases would not be larger than 106 .

 

输出

The output contains exactly T lines. For each test case, if one can not spell the serenade by using the strings in F, output −1. Otherwise, output the minimum number of strings in F to split S according to aforementioned rules.
Repetitive strings should be counted repeatedly.

 

样例输入

8
ffcfffcffcff
cffcfff
cffcff
cffcf
ffffcffcfff
cffcfffcffffcfffff
cff
cffc

 

样例输出

Case #1: 3
Case #2: 2
Case #3: 2
Case #4: -1
Case #5: 2
Case #6: 4
Case #7: 1
Case #8: -1

 

提示

Shift the string in the first test case, we will get the string “cffffcfffcff”and it can be split into “cffff”, “cfff” and “cff”.

题意:

C_{0}= ' f ' ,    C_{1}=' ff '     ,C_{2}= 'cff ' ,  C_{3}=' cfff '   . . . . . . .  C_{n}=C_{n-1}+ ' f ‘;

给定一组可以成环的字符串,问其可有几个上述字段组成。

分析:分段判断即可

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define ll long long int
char maze[1000010];
int main()
{
    int f,sum,node=1;
    scanf("%d",&f);
    while(f--){
        sum=0;
        memset(maze,'\0',sizeof(maze));
        scanf("%s",maze);
        int l=strlen(maze);

        int flag=1,num;
        for(int i=0;i<l&&flag;i++){
            if(maze[i]!='c'&&maze[i]!='f')
                flag=0;
        }

        int countt=0;
        while(maze[countt]!='c'&&countt<l)
            countt++;

        if(countt>=l){
            printf("Case #%d: %d\n",node,(l+1)/2);
            node++;
            continue;
        }

        int k;
        for(int t=countt;t<l&&flag;){
            k=t+1;
            while(k<l&&maze[k]!='c')
                k++;
            int temp=k-t-1;
            if(k>=l)
                temp+=countt;
            if(temp<2){
                flag=0;
                break;
            }
            t=k;
            sum++;
        }

        if(flag==0)
            printf("Case #%d: -1\n",node);
        else
            printf("Case #%d: %d\n",node,sum);
        node++;
    }


    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值