D - Prime Ring Problem HDU - 1016
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.Sample Input
6 8Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
素数环问题:在环中填入1~n,每个数和相邻的数之和均为素数,输出所有的方案(以1开头)
暴力DFS,第一个位置填1,然后一个位置一个位置地填1~n里没被填过的数,判断和上一个位置的和是否为素数,到最后一个要记得判断+1是否是素数
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <cmath>
#include <algorithm>
#include <string>
#include <map>
#include <stack>
#include <set>
using namespace std;
const int maxn=33;
int ans[maxn];
int f[maxn];
int n;
bool ss(int x)
{
for(int i=2;i<=sqrt(x);i++)
{
if(x%i==0)return false;
}
return true;
}
bool OK(int i,int x)
{
if(f[x]||!ss(x+ans[i-1]))return false;
return true;
}
void print()
{
for(int i=1;i<=n;i++)
{
if(i!=1)printf(" ");
printf("%d",ans[i]);
}
printf("\n");
}
void DFS(int x,int n)
{
if(x==n+1)
{
if(ss(ans[x-1]+ans[1]))print();
return;
}
for(int i=2;i<=n;i++)
{
if(OK(x,i))
{
f[i]=1;
ans[x]=i;
DFS(x+1,n);
f[i]=0;
}
}
}
int main()
{
int T=0;
while(~scanf("%d",&n))
{
printf("Case %d:\n",++T);
ans[1]=1;
memset(f,0,sizeof(f));
f[1]=1;
DFS(2,n); printf("\n");
}
return 0;
}