HDU 2056 Rectangles

Rectangles

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 26882 Accepted Submission(s): 8705

Problem Description

Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .

Input

The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).

Output

For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.

Sample Input

1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50

Sample Output

1.00
56.25


http://acm.hdu.edu.cn/showpro...

Accepted Code

// Author : Weihao Long
// Created : 2017/12/27

#include <bits/stdc++.h>

using namespace std;

int main() {
    double x1, y1, x2, y2, x3, y3, x4, y4;
    double x[4], y[4];
    double s, l, h;
    while (cin >> x1 >> y1 >> x2 >> y2 >> x3 >> y3 >> x4 >> y4) {
        x[0] = x1; x[1] = x2; x[2] = x3; x[3] = x4;
        y[0] = y1; y[1] = y2; y[2] = y3; y[3] = y4;
        sort(x, x + 4);
        sort(y, y + 4);
        l = fabs(x2 - x1) + fabs(x4 - x3) - (x[3] - x[0]);
        h = fabs(y2 - y1) + fabs(y4 - y3) - (y[3] - y[0]);
        s = l * h;
        if (l <= 0 || h <= 0)
            s = 0.00;
        printf("%.2lf\n", s);
    }
    return 0;
}

Notes

题意:
给四个平面直角坐标,可以构成两个矩形,求相交面积。

感受:
直接暴力求解很容易疏忽,改进后的求长宽的方法(见代码)就有效地避免了考虑疏忽。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值