poj Safecracker

/**
C:Safecracker查看提交统计提问总时间限制: 1000ms内存限制: 65536kB
描述
"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them,
along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and
wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers,
and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually
at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the
safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the
target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation,
where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is
more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a
dictionary."

v - w2+ x3- y4+ z5= target

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 92+ 53- 34+ 25= 1. There are actually
several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the
engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't
 exist then."


"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations.



输入
Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at
most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input.
输出
For each line output the unique Klein combination, or 'no solution' if there is no correct combination. Use the exact format shown below."
样例输入
1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END样例输出
LKEBA
YOXUZ
GHOST
no solution
*/


#include <cstdio>
#include <algorithm>
#include <string>
#include <cstdlib>
#include <cmath>
#include <iostream>
#include <cstring>

using namespace std;
int num = 0;
char tep[12];
int let[12] = {0};
bool used[12] = {0};
int ans[6] = {0};
int mark = 0;


bool judge(int a, int b, int c, int d, int e, int f)
{
    return a - b*b+ c*c*c- d*d*d*d+ e*e*e*e*e == f;
}

struct gr
{
    bool operator()(const int &a, const int &b)const
    {
        return a > b;
    }
};

void choose(int a, int b)
{
    if(mark) return;
    if(a == 5)
    {
        if(judge(ans[0], ans[1],ans[2],ans[3],ans[4], num))
        {
            for(int i = 0; i < 5; ++i) printf("%c", ans[i] + 'A' - 1);
            printf("\n") ;
            //for(int i = 0; i < 5; ++i) printf("%d", ans[i]);
            //printf("\n") ;
            mark = 1;
        }
        return;
    }
    for(int j = 0; j < b; ++j)
    {
        if(mark) return;
        if(!used[j])
        {
            used[j] = 1;
            ans[a] = let[j];
            choose(a + 1, b);
            used[j] = 0;
        }
    }
    return;
}



int main()
{
    while(true)
    {
        mark = 0;
        scanf("%d %s", &num, tep);
        int t = strlen(tep);
        //printf("%d\n", t);
        if(t < 5) break;
        for(int i = 0; i < t; ++i)
            let[i] = tep[i] - 'A' + 1;
        sort(let, let + t, gr() );
        for(int i = 0; i < t; ++i)
        //printf("%d ", let[i]);
        choose(0, t);
        if(!mark) printf("no solution\n");
    }
    return 0;
}

转载于:https://my.oschina.net/locusxt/blog/135179

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值