UVALive2362 POJ1004 HDU1064 ZOJ1048 Financial Management【数学计算】

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 184289 Accepted: 69774

Description

Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

Input

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

Sample Input

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

Sample Output

$1581.42

Source



Regionals 2001 >> North America - Mid-Atlantic USA


问题链接UVALive2362 POJ1004 HDU1064 ZOJ1048 Financial Management

题意简述输入12个数,计算其平均值。

问题分析:(略)

程序说明编写程序时,考虑到C++处理输入比较方便,所以使用C++语言编程。然而,输出需要指定格式是还是C语言方便,所以就用函数printf()来处理输出。


AC的C语言程序如下:

/* UVALive2362 POJ1004 HDU1064 ZOJ1048 Financial Management */

#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
    double val, sum;

    sum = 0;
    for(int i=1; i<=12; i++) {
        cin >> val;
        sum += val;
    }

    printf("$%.2f\n", sum / 12);

    return 0;
}


转载于:https://www.cnblogs.com/tigerisland/p/7564399.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值