N - Robot Motion(第二季水)

Description


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are
N north (up the page)         S south (down the page)         E east (to the right on the page)         W west (to the left on the page)        
For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.        
Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.        
You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.        
                

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.        
                

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.        
                

Sample Input

3 6 5 NEESWE WWWESS SNWWWW 4 5 1 SESWE EESNW NWEEN EWSEN 0 0
                

Sample Output

10 step(s) to exit 3 step(s) before a loop of 8 step(s)
 
 
这个题错的一塌糊涂
刚开始写的代码 不知道哪里有错 ,结果错误
#include<iostream>
#include<string.h>
using namespace std;
char str[1000][1000];
int x[100],y[100],p,q;
void f(char ch)
{
    if(ch=='N')p--;
    if(ch=='S')p++;
    if(ch=='E')q++;
    if(ch=='W')q--;
}
int main()
{
    int m,n,l,i,k,t;
    while(cin>>m>>n){
        if(m==0&&n==0)break;
        cin>>l;
        x[0]=0;
        y[0]=l-1;
        memset(str,'\0',sizeof(str));
        for(i=0;i<m;i++){
            for(int j=0;j<n;j++)cin>>str[i][j];
        }
        k=0;
        while(1){
            p=x[k];
            q=y[k];
            f(str[x[k]][y[k]]);
            if(p<0||p==m||q<0||q==n){
                cout<<k+1<<" step(s) to exit"<<endl;
                break;
            }
            t=0;
            for(i=0;i<k;i++){
                if(x[k]==x[i]&&y[k]==y[i]){
                    t=i;
                    break;
                }
            }
            if(t!=0){
                cout<<t<<" step(s) before a loop of "<<k-t<<" step(s)"<<endl;
                break;
            }
            k++;
            x[k]=p;
            y[k]=q;
        }
    }
    return 0; 
}

检查半天没有结果,就换一种方法来写,结果 超时

#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
char str[100][100];
int x[100][100];
int main()
{
    int m,n,l;
    while(scanf("%d%d",&m,&n)){
        if(m==0&&n==0)break;
        scanf("%d",&l);
        memset(str,'\0',sizeof(str));
        memset(x,0,sizeof(x));
        int p=0,q=l-1,k=0;
        for(int i=0;i<m;i++)scanf("%s",str[i]);
        while(1)
        {  
        k++;
            if(str[p][q]=='N'&&!x[p][q]){
               x[p][q]=k;
                p--;
            }
            else if(str[p][q]=='S'&&!x[p][q]){
                x[p][q]=k;
                p++;
            }
            else if(str[p][q]=='E'&&!x[p][q]){
                x[p][q]=k;
                q++;
            }
            else if(str[p][q]=='W'&&!x[p][q]){
               x[p][q]=k;
               q--;
            }
            else if(x[p][q]){
            printf("%d step(s) before a loop of %d step(s)\n",x[p][q]-1,k-x[p][q]);
                break;
            }
            else if(p<0||q<0||p==n||q==m){
                printf("%d step(s) to exit\n",k-1);
                break;
            }
          
        }
    }
    return 0; 
}


 

最后最后的正确代码,分四个情况,每次移动后都判断是否越界,不越界就走下一步,越界就分情况输出结果

#include<stdio.h>
#include<string.h>
char map[100][100];
int t[100][100];
int main()
{
    int n,m,k;
    int x,y;
    while(scanf("%d%d",&n,&m)!=EOF&&(m+n)){
        scanf("%d",&k);
        for(int i=0;i<n;i++) scanf("%s",&map[i]);
        x=0;
        y=k-1;
        memset(t,0,sizeof(t));
        t[x][y]=1;
        while(1){
             if(map[x][y]=='E'){
                y++;
                if(y==m){
                    printf("%d step(s) to exit\n",t[x][y-1]);
                    break;
                }    
                if(t[x][y]!=0){
                    printf("%d step(s) before a loop of %d step(s)\n",t[x][y]-1,t[x][y-1]-t[x][y]+1);
                    break;
                }    
                t[x][y]=t[x][y-1]+1;
            }    
            else if(map[x][y]=='W'){
                y--;
                if(y<0){
                    printf("%d step(s) to exit\n",t[x][y+1]);
                    break;
                }    
                if(t[x][y]!=0){
                    printf("%d step(s) before a loop of %d step(s)\n",t[x][y]-1,t[x][y+1]-t[x][y]+1);
                    break;
                }    
                t[x][y]=t[x][y+1]+1;
            }    
            else if(map[x][y]=='N'){
                x--;
                if(x<0) {
                    printf("%d step(s) to exit\n",t[x+1][y]);
                    break;
                }   
                if(t[x][y]!=0){
                    printf("%d step(s) before a loop of %d step(s)\n",t[x][y]-1,t[x+1][y]-t[x][y]+1);
                    break;
                }    
                t[x][y]=t[x+1][y]+1;
            }    
            else{
                x++;
                if(x==n){
                    printf("%d step(s) to exit\n",t[x-1][y]);
                    break;
                }    
                if(t[x][y]!=0){
                    printf("%d step(s) before a loop of %d step(s)\n",t[x][y]-1,t[x-1][y]-t[x][y]+1);
                    break;
                }    
                t[x][y]=t[x-1][y]+1;
            }    
        }    
    }    
    return 0;
}

题不难,注意思路!!!

转载于:https://www.cnblogs.com/farewell-farewell/p/5199067.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
牙科就诊管理系统利用当下成熟完善的SSM框架,使用跨平台的可开发大型商业网站的Java语言,以及最受欢迎的RDBMS应用软件之一的Mysql数据库进行程序开发。实现了用户在线查看数据。管理员管理病例管理、字典管理、公告管理、药单管理、药品管理、药品收藏管理、药品评价管理、药品订单管理、牙医管理、牙医收藏管理、牙医评价管理、牙医挂号管理、用户管理、管理员管理等功能。牙科就诊管理系统的开发根据操作人员需要设计的界面简洁美观,在功能模块布局上跟同类型网站保持一致,程序在实现基本要求功能时,也为数据信息面临的安全问题提供了一些实用的解决方案。可以说该程序在帮助管理者高效率地处理工作事务的同时,也实现了数据信息的整体化,规范化与自动化。 管理员在后台主要管理病例管理、字典管理、公告管理、药单管理、药品管理、药品收藏管理、药品评价管理、药品订单管理、牙医管理、牙医收藏管理、牙医评价管理、牙医挂号管理、用户管理、管理员管理等。 牙医列表页面,此页面提供给管理员的功能有:查看牙医、新增牙医、修改牙医、删除牙医等。公告信息管理页面提供的功能操作有:新增公告,修改公告,删除公告操作。公告类型管理页面显示所有公告类型,在此页面既可以让管理员添加新的公告信息类型,也能对已有的公告类型信息执行编辑更新,失效的公告类型信息也能让管理员快速删除。药品管理页面,此页面提供给管理员的功能有:新增药品,修改药品,删除药品。药品类型管理页面,此页面提供给管理员的功能有:新增药品类型,修改药品类型,删除药品类型。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值