计算几何 - 最近点对 分治法

最近点对

clipboard.png

clipboard.png

clipboard.png

样题 HOJ 1007

题目

Quoit Design

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41399    Accepted Submission(s): 10779


Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
 

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
 

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places. 
 

Sample Input
2
0 0
1 1
2
1 1
1 1
3
-1.5 0
0 0
0 1.5
0
 

Sample Output
0.71
0.00
0.75
 

Author
CHEN, Yue
 

Source
ZJCPC2004
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1006 1009 1005 1008 1004 

注意

最近点对是直径,要求的是半径。
浮点型,两位小数。

伪代码

double FindShortPairDC(int left,int right)   //DC代表divide and conquer,分治。 left、right为元素下标 
{
   if (right - left <= 2) //子集中少于三个点为最小分治状态。如果三个点仍继续递归,会出现一边只有1个点的情况。 
        return FindShortPair(left, right);
   mid = (left+right)/2;
   dL = FindShortPairDC(left, mid);
   dR = FindShortPairDC(mid+1, right);
   d = min(dL, dR)  
   for (i=mid; i >= left; i--)
   {
         if(x[mid] - x[i] > d) //横坐标之差 
           break;
         for(j=mid+1;i<=right;i++)
         {
        if(x[j] - x[mid] > d)
         break;
         if(temp = dist(i,j),temp < d)
           d = temp;     
      }
   }
   return d;
}

TLE代码

插入排序

#include <stdlib.h>
#include <math.h>
#include <iostream>
using namespace std;

#define min(dL,dR) dL<dR?dL:dR
#define dist(i,j)  sqrt( (x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]))

double x[100002],y[100002];

double FindShortPair(int left,int right)
{
    int i,j,flag = 1;
    double d ,temp;
    for(i=left;i<right;i++)
      for(j=i+1;j<=right;j++)
      {
          temp = dist(i,j);
          if(flag){
                d = temp;
                flag = 0;
        }
          if(temp < d)
            d = temp;
      }
    return d;
}

double FindShortPairDC(int left,int right)   //DC代表divide and conquer,分治。 left、right为元素下标 
{
   int mid,i,j;
   double dL,dR,d,temp; 
   if (right - left <= 2) //子集中少于三个点为最小分治状态。如果三个点仍继续递归,会出现一边只有1个点的情况。 
        return FindShortPair(left, right);
   mid = (left+right)/2;
   dL = FindShortPairDC(left, mid);
   dR = FindShortPairDC(mid+1, right);
   d = min(dL, dR) ; 
   for (i=mid; i >= left; i--)
   {
         if(x[mid] - x[i] > d) //横坐标之差 
           break;
         for(j=mid+1;i<=right;i++)
         {
        if(x[j] - x[mid] > d)
         break;
         if(temp = dist(i,j),temp < d)
           d = temp;     
      }
   }
   return d;
}

int main(){
    int n,i,j;
    double a,b;
    //读入点集,并按x坐标进行插入排序 
    while(scanf("%d",&n),n!=0)
    {
        for(i=1;i<=n;i++)
        {
           scanf("%lf %lf",&a,&b); //带插入元素 
           if(i==1){ //没有已排好序的元素 
                x[1] = a;
                y[1] = b;
           } 
           else{
                j=i-1;
                while(j>=1 && a<x[j]) //将较大的元素往后挪 
                {
                    x[j+1] = x[j];
                    y[j+1] = y[j];
                    j--;
              }
              
              x[j+1] = a; //insert 
             y[j+1] = b; 
           }
        }
        
        
        double d = FindShortPairDC(1,n);
        printf("%.2lf\n",d/2);
    }
    return 0;
}

21457204_1326898064RUxx.jpg

快排

将插入排序改为快排,还是 5000ms,代码如下:

#include <stdlib.h>
#include <math.h>
#include <stdio.h>
//#include <iostream>
//using namespace std;

/**
算法复杂度常数因子优化
1、前期比较距离用平方,最后再开方 
2、 
**/
#define min(dL,dR) dL<dR?dL:dR
#define dist(i,j)  sqrt( (x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]))
#define sdist(i,j)  (x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j])
double x[100002],y[100002];

/**
快排
**/ 
void quicksort(int left,int right)
{
    if(left < right)
    {
        double key = x[left];/*用字表的第一个记录作为枢轴*/
        double keyy = y[left];
        int low = left;
        int high = right;
        while(low < high)
        {
            while(low < high && x[high] >= key)
                high--;
            x[low] = x[high];/*将比第一个小的移到低端*/
            y[low] = y[high];
            while(low < high && x[low] <= key)
                 low++;
            x[high] = x[low]; /*将比第一个大的移到高端*/
            y[high] = y[low];
        }
        x[low] = key; /*枢轴记录到位*/
        y[low] = keyy;
        quicksort(left,low-1);
        quicksort(low+1,right);
        
    }
}

double FindShortPair(int left,int right)
{
    int i,j,flag = 1;
    double d ,temp;
    for(i=left;i<right;i++)
      for(j=i+1;j<=right;j++)
      {
          temp = sdist(i,j);
          if(flag){
                d = temp;
                flag = 0;
        }
          if(temp < d)
            d = temp;
      }
    return sqrt(d);
}

double FindShortPairDC(int left,int right)   //DC代表divide and conquer,分治。 left、right为元素下标 
{
   int mid,i,j;
   double dL,dR,d,temp,dd; 
   if (right - left <= 2) //子集中少于三个点为最小分治状态。如果三个点仍继续递归,会出现一边只有1个点的情况。 
        return FindShortPair(left, right);
   mid = (left+right)/2;
   dL = FindShortPairDC(left, mid);
   dR = FindShortPairDC(mid+1, right);
   d = min(dL, dR) ; 
   dd = d*d;
   for (i=mid; i >= left; i--)
   {
         if(x[mid] - x[i] > d) //横坐标之差 
           break;
         for(j=mid+1;i<=right;i++)
         {
        if(x[j] - x[mid] > d)
         break;
         if(temp = sdist(i,j),temp < dd)
           dd = temp;     
      }
   }
   return sqrt(dd);
}

int main(){
    int n,i,j;
    double a,b;
    //读入点集,并按x坐标进行插入排序 
    while(scanf("%d",&n),n!=0)
    {
        for(i=1;i<=n;i++)
        {
           scanf("%lf %lf",&x[i],&y[i]); //带插入元素 
        }
        
        quicksort(1,n);
        
        double d = FindShortPairDC(1,n);
        printf("%.2lf\n",d/2);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值