LightOJ Problem 1275 【解方程水题】

Time Limit: 2000MSMemory Limit: 32768KB64bit IO Format: %lld & %llu

Description

A group of N Internet Service Provider companies (ISPs) use a private communication channel that has a maximum capacity of C traffic units per second. Each company transfers T traffic units per second through the channel and gets a profit that is directly proportional to the factor T(C - T*N). The problem is to compute the smallest value of T that maximizes the total profit the NISPs can get from using the channel. Notice that N, C, T, and the optimal T are integer numbers.

Input

Input starts with an integer T (≤ 20), denoting the number of test cases.

Each case starts with a line containing two integers N and C (0 ≤ N, C ≤ 109).

Output

For each case, print the case number and the minimum possible value of T that maximizes the total profit. The result should be an integer.

Sample Input

6

1 0

0 1

4 3

2 8

3 27

25 1000000000

Sample Output

Case 1: 0

Case 2: 0

Case 3: 0

Case 4: 2

Case 5: 4

Case 6: 20000000

求一元二次函数的最大值点,只不过因为解是整数,四舍五入会有偏差,要多多判断解的前一个值。

#include <bits/stdc++.h>
using namespace std;

int main() {
    int t;
    double n, c;
    scanf("%d", &t);
    int cnt = 0;
    while (t--) {
        scanf("%lf%lf", &n, &c);
        if(n == 0){
            printf("Case %d: 0\n", ++cnt); continue;
        }
        long long ans = c/(2*n);

        if (ans*(c-ans*n) < (ans+1)*(c-(ans+1)*n))
            ans++;
        printf("Case %d: %lld\n", ++cnt, ans);
    }
    return 0;
}

 

 
 

 

 

转载于:https://www.cnblogs.com/cniwoq/p/6770886.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值