【Light OJ 】--1275(一元二次函数的驻点)

A group of N Internet Service Provider companies (ISPs) use a private communication channel that has a maximum capacity of C traffic units per second. Each company transfers T traffic units per second through the channel and gets a profit that is directly proportional to the factor T(C - T*N). The problem is to compute the smallest value of T that maximizes the total profit the N ISPs can get from using the channel. Notice that N, C, T, and the optimal T are integer numbers.

Input

Input starts with an integer T (≤ 20), denoting the number of test cases.

Each case starts with a line containing two integers N and C (0 ≤ N, C ≤ 109).

Output

For each case, print the case number and the minimum possible value of T that maximizes the total profit. The result should be an integer.

Sample Input

6

1 0

0 1

4 3

2 8

3 27

25 1000000000

Sample Output

Case 1: 0

Case 2: 0

Case 3: 0

Case 4: 2

Case 5: 4

Case 6: 20000000

题目大意:其实也就是一个公式y=nx^2-cx的最大值,其中所有的值都是整数

思路:就是X=c/(2*n)或者是c/(2*n)+1,因为是整数嘛,不一定整除的

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#define ll long long
using namespace std;
int n,c;
int main()
{
    int t,kase=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&c);

        if(n==0||c==0)
        {
            printf("Case %d: 0\n",kase++);
            continue;
        }
        int m=c/(2*n);
        if((c*m-n*m*m)>=(c*(m+1)-n*(m+1)*(m+1)))
            printf("Case %d: %d\n",kase++,m);
        else
            printf("Case %d: %d\n",kase++,m+1);

    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值