poj1338(Ugly Numbers)

Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence
1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ...
shows the first 10 ugly numbers. By convention, 1 is included.
Given the integer n,write a program to find and print the n'th ugly number.
Input
Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.
Output
For each line, output the n’th ugly number .:Don’t deal with the line with n=0.
Sample Input
1
2
9
0
Sample Output
1
2
10

分析:打表,好笨的方法=_=.
#include<cstdio>
#include<algorithm>
using namespace std;
long long a[30000],cnt=0;
long long Pow(int x,int k)
{
    if(k==0) return 1;
    if(k==1) return x;
    long long y=Pow(x,k/2);
    y*=y;
    if(k%2) y*=x;
    return y;
}
void f()
{
    long long N=(long long)17592186044416;
    for(int i=0;i<=44;i++)
    {
        long long ans2=Pow(2,i);
        for(int j=0;j<30;j++)
        {
            long long ans3=Pow(3,j);
            for(int k=0;k<20;k++)
            {
                long long ans5=Pow(5,k);
                if(ans5<=N/ans2/ans3) 
                    a[cnt++]=ans2*ans3*ans5;
            }
        }
    }
    sort(a,a+cnt);
}
int main()
{
    f();
    int n;
    while(scanf("%d",&n)&&n)
        printf("%d\n",a[n-1]);
    return 0;
}
View Code

 




转载于:https://www.cnblogs.com/ACRykl/p/8696839.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值