Max Sum

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

 

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

 

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
 
 
根据题目要求,每一个位置有不同的状态和,用dp[]数组记录当前的和,当从第一个数开始,依次往后累加,dp[i]记录i位置的和,当dp[i-1]<0时应该舍弃前面的和,将当前位置的arr[i]数值赋值给dp[i],然后寻找dp[i](i:1~n)中的最大值,然后记录当前的位置为end,再以当前位置往前寻找 start ,如果出现dp[i](i:end~0)<0则退出并将start赋值为i

#include<stdio.h>
int main(){
int t,n,max,start,end;
int arr[100001];
int dp[100001];
scanf("%d",&t);
for(int j=0;j<t;j++){
max =-9999;
scanf("%d",&n);
for(int i=0;i<n;i++){
scanf("%d",&arr[i]);
}

dp[0]=arr[0];
start=end=0;
for(int i=1;i<n;i++){
if(dp[i-1]>=0){
dp[i]=dp[i-1]+arr[i];
}else
dp[i]=arr[i];
}
for(int i=0;i<n;i++){
if(max<dp[i]){
max=dp[i];
end = i;
}
}
// start = end;// 这里是一个关键点,在这里wrong N次
for(int i=end;i>=0;i--){
if(dp[i]>=0){
start=i;
}else
break;
}
printf("Case %d:\n",j+1);
printf("%d %d %d\n",max,start+1,end+1);
if(j!=t-1)
printf("\n");
}

return 0;
}

转载于:https://www.cnblogs.com/hoojjack/p/3973479.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值