最大子序列(区间求和)

Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

题意:给出一个数列,求出这个数列的最大子序列的和

思路:可以先定义一个sum,表示连续数字的和,如果sum小于0了,则把sum初始化为0,然后再定义一个max,存储最大sum,也就是最大连续数字的和。

一定要把max定义为为无穷大不然如果是全负数序列的话就会出错。

代码如下:

#include<stdio.h>
int a[100010];
int main()
{
	int T,i,k,n,sum,max,begin,end,t;
	scanf("%d",&T);
	for(k=1;k<=T;k++)
	{
		scanf("%d",&n);
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		sum=0;
		max=-99999999;
		t=begin=end=1;
		for(i=1;i<=n;i++)
		{
			sum+=a[i];
			if(sum>max)
			{
				max=sum;
				begin=t;
				end=i;
			}
			if(sum<0)
			{
				sum=0;
				t=i+1;
			}
		}
		printf("Case %d:\n%d %d %d\n",k,max,begin,end);
		if(k!=T)
			printf("\n");//控制输出格式
	}
	return 0;
}

 

  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值