HDU 4908 BestCoder Sequence(BestCoder Round #3)

Problem Description:
Mr Potato is a coder.
Mr Potato is the BestCoder.

One night, an amazing sequence appeared in his dream. Length of this sequence is odd, the median number is M, and he named this sequence as  Bestcoder Sequence.

As the best coder, Mr potato has strong curiosity, he wonder the number of consecutive sub-sequences which are  bestcoder sequences in a given permutation of 1 ~ N.
 
Input:
Input contains multiple test cases. 
For each test case, there is a pair of integers N and M in the first line, and an permutation of 1 ~ N in the second line.

[Technical Specification]
1. 1 <= N <= 40000
2. 1 <= M <= N
 
Output:
For each case, you should output the number of consecutive sub-sequences which are the  Bestcoder Sequences
 
Sample Input:
1 1
1
5 3
4 5 3 2 1
 
Sample Output:
1
3
 
Hint:
For the second case, {3},{5,3,2},{4,5,3,2,1} are Bestcoder Sequence.
 
题意:有一个1~n的序列,现在我们要找到这个序列以m为中位数(eg:1 2 3 4 5 || 5 4 3 2 1,这是两个以3为中位数的序列)的连续子序列有多少个。
 
这里先来看一下1 2 3 4 5这个序列,首先我们可以得到它的sum值(请结合下面的代码来看):
a[i]         1      2      3      4      5
sum[i]    -1    -2     -2     -1     0
由于我们下标都是从1开始的,那么我们可以加上a[0]和sum[0],变成
a[i]         0      1      2      3      4      5
sum[i]    0      -1    -2     -2     -1     0
离散化之后(变成正数,便于模拟,这里假如加上的是40000)
a[i]                         0             1           2           3            4          5
sum[i]                    0            -1          -2          -2          -1          0
sum[i]+40000     40000     39999    39998    39998    39999    40000                         
首先从0~x-1遍历,这时b[40000] = 1, b[39999] =1, b[39998]=1;那我们在遍历x~n时由上面分析得也会遇见这三个值,那么我们最终就会发现满足条件的序列就是三个。(注意b数组的下标是sump[i]+40000)
 
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<queue>
#include<algorithm>
using namespace std;

const int N=1e6+10;
const int M=50000;
const int INF=0x3f3f3f3f;
int a[N], sum[N], b[N]; 

int main ()
{
    int n, m, i, x, ans;

    while (scanf("%d%d", &n, &m) != EOF)
    {
        memset(sum, 0, sizeof(sum));
        memset(b, 0, sizeof(b));
        ans = 0;

        for (i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
            
            sum[i] = sum[i-1];
            if (a[i] < m) sum[i]--; ///比中位数小--
            if (a[i] > m) sum[i]++; ///比中位数大++
            
            if (a[i] == m)
                x = i;
        }

        for (i = 0; i < x; i++)
            b[sum[i]+M]++; ///由于我们的sum值可能是负数,那么我们需要将所有的数变成正数,为了结果不受影响,加上一个比较大的数

        for (i = x; i <= n; i++)
            ans += b[sum[i]+M]; ///首先我们要明白当两个位置的sum值相等时,那么这中间就会产生一个符合题意的序列

        printf("%d\n", ans);
    }

    return 0;
}

转载于:https://www.cnblogs.com/syhandll/p/4897747.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值