Catch That Cow POJ - 3278 [kuangbin带你飞]专题一 简单搜索

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 
一道bfs,开始考虑模拟,后来发现条件很多要考虑的东西太多了,就用了bfs
然后就是想界限问题,开始觉得要尽量小,后来看了别人代码再看数据觉得直接用题目中的数据做界限可以出结果
接着是各种调bug,其实方法一开始就写对了,但因为中间一两行代码的错误和没有发现导致不停的错
唉~今天的第二次了,第一次调了半个多小时,第二次直接调了一个半小时
#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#include<cmath>
using namespace std;
#define maxn 100010
int n,k,vis[maxn];
struct node{
    int x,step;
};
void bfs(){
    node p;
    p.x = n,p.step = 0;
    vis[n] = 1;
    queue<node> q;
    q.push(p);
    while(!q.empty()){
        node tmp = q.front();
        q.pop();
        if(tmp.x == k){
            cout << tmp.step << endl;
            return;
        }
        for(int i=0;i<3;i++){
            int xx;
            if(i == 0){
                xx = tmp.x + 1;
            }
            else if(i == 1){
                xx = tmp.x - 1;
            }
            else xx = tmp.x * 2;
            if(xx < 0 || xx > maxn){
                continue;
            }
            if(!vis[xx]){
                vis[xx] = 1;//注意vis数组
                node tp;//这里新建一个结构体对象,不要在原来的tmp上加减!!!  在这里调了一个半小时!!!
                tp.x = xx;
                tp.step = tmp.step + 1;
                q.push(tp);
            }
        }
    }
}
int main(){
    while(cin >> n >> k){
        memset(vis,0,sizeof(vis));
        if(n<k){
            bfs();
        }
        else{
            cout << n - k << endl;
        }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/l609929321/p/7517556.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值