[kuangbin]专题一 简单搜索 Catch That Cow POJ - 3278【BFS】

【题目描述】
Farmer John has been informed of the location of a fugitive cow and wants to catch her mmediately. He starts at a point N (0≤N≤100000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

农民John获知了一头逃亡的牛的位置并想去立刻抓住她。他从N (0 ≤ N ≤ 100,000) 开始,并且牛在同一行的K位置。农民John有两种移动方式:步行和传送。

  • 步行:农民John可以在一分钟内从任意点X移动到点X - 1或点X + 1
  • 传送:农民John可以在一分钟内从任何点X移动到点2×X。

如果母牛不动,农场主约翰需要多长时间才能找回它?

【输入】
Line 1: Two space-separated integers: N and K

第一行:两个用空格分开的整数N和K

【输出】
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

第1行:最短的时间,在几分钟内,农夫约翰就能抓住逃亡的母牛。

【样例输入】
5 17

【样例输出】
4

【样例解释】
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
农夫约翰找到逃亡牛的最快方法是沿着以下的道路移动:5-10-9-18-17,这需要4分钟。

题目链接:https://cn.vjudge.net/problem/POJ-3278

除了暴搜想不到更好的办法,因为要求最短时间,所以用bfs

#include <iostream>
#include <cstring>
#include <queue>
using namespace std;
static const int MAXN=200000;
bool vis[MAXN+10];
int n,k;
struct Node{
    int x,step;
};
void bfs(Node node)
{
    queue<Node> Q;
    Node now,next;
    Q.push(node);
    vis[node.x]=true;
    while(!Q.empty())
    {
        now=Q.front();
        Q.pop();
        if(now.x==k)
        {
            cout<<now.step<<endl;
            return;
        }
        next.x=now.x-1;
        next.step=now.step+1;
        if(next.x>=0 && next.x<MAXN && !vis[next.x])
        {
            vis[next.x]=true;
            Q.push(next);
        }
        next.x=now.x+1;
        next.step=now.step+1;
        if(next.x>=0 && next.x<MAXN && !vis[next.x])
        {
            vis[next.x]=true;
            Q.push(next);
        }
        next.x=now.x*2;
        next.step=now.step+1;
        if(next.x>=0 && next.x<MAXN && !vis[next.x])
        {
            vis[next.x]=true;
            Q.push(next);
        }
    }
}
int main()
{
    std::ios::sync_with_stdio(false);
    std::cin.tie(0),cout.tie(0);
    cin>>n>>k;
    memset(vis,false,sizeof(vis));
    bfs(Node{n,0});
    return 0;
}
  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值